PDA

View Full Version : Cannot load a project, not even samples



MichaelN
11-21-2009, 06:00 PM
I try to load my own project into IS 2010 Express and I get the message windows shown below. The same thing happens if I try to load one of the IS samples. I attached the error window from each case.

I'm dead in the water. Any ideas?

Software is running on Vista 64 Ultimate.

DebbieL
11-23-2009, 10:43 AM
The Express edition of InstallShield does not have InstallScript support, so you will not be able to use this edition to open any of the sample projects in the InstallShield Program Files Folder\Samples\InstallScript directory. Thus, the error in the second screen shot is expected.

When you open an InstallShield 2010 project in InstallShield 2010 SP1, InstallShield upgrades the project to InstallShield 2010 SP1. (InstallShield 2010 SP1 includes support for tables that were not available in InstallShield 2010 projects, and these tables need to be added during the upgrade.) It is not possible to open InstallShield 2010 SP1 projects in earlier versions of InstallShield (including InstallShield 2010 without SP1).

Thus, is it possible that your project was previously opened in InstallShield 2010 SP1, but now you are trying to open it in InstallShield 2010 (without SP1)? If so, you'll probably want to install the SP1 patch. Here's a link to the SP1 KB article:
http://support.installshield.com/kb/view.asp?articleid=Q206429

mberterm
11-23-2009, 10:48 AM
Express does not open ISM files (the sample InstallScript project) and so that message would be expected.

However, the ISE is its (current) native project extension. (Not to confuse the issue, but in the past it had used ISM but then moved to ISE for things like better side by side functionality in Visual Studio.)

What is the history of this ISE project file? Especially, do you have any other developers using Express 2010 and might they have already installed the SP1 to their machine?

Also, what is the version information from your installation of Express (from the Help | About dialog)?

Send me a pm if you can send me this ISE or a reproducible sample ISE.

MichaelN
12-08-2009, 04:19 PM
I have resolved the issue. Here is the scenario, followed by my resolution:

I puchased an upgrade to ISE 2010 and installed it on a Win7 x64 machine. That machine got zapped and I had to switch to a different machine until it was repaired. The loaner machine used Vista 64 Ultimate. I contacted IS support about this and explained the situation. They told me I could have permission to install ISE 2010 on another machine but for a short time. So I installed ontl Vista64u the exact same download I had installed onto Win 7x64. It was the software on Vista64u that refused to open installations I had made on the Win7x64 machine. So I had to create the installations totally from scratch on the loaner machine (Vista64u).

Here is what I believe is the situation:

When ISE 2010 was activated on the loaner machine, it was activated as a time-limited earlier release which would not recognize the ISE files I created using the latest retail version. Would that be accurate?

DebbieL
12-08-2009, 05:18 PM
The only reason I can think of in your case where you would have encountered the first error (".ise cannot be opened by this version of InstallShield. This may be because the project was created with a more recent version of InstallShield or the project has been updated to a more recent version") is because machine #1 had IS 2010 SP1, but machine #2 had IS 2010 without SP1.

MichaelN
12-08-2009, 05:22 PM
That could be the case because machine #1 had ISE 2010 on it for about a week before it got fried and perhaps there was a service pack update during that time.

Michael