PDA

View Full Version : The setup doesn't ask me if I want to remove the previous version that's installed



SynnosG
01-08-2009, 04:39 PM
I upgraded a project from Installshield Express 3.5 (SP4).
I am using the same product code and upgrade code as I did in the original project that I updated. The problem is that when I run the setup created in 2009 Express it doesnt prompt me for any verification like "A previous version is already installed...".

How can I force this check?

I run some tests:

1. Build a setup in 2009 Express, install it on a fresh system. Then Build a setup (same product and upgrade code) in 3.5 and try to install it: Warning message that another version is installed [GOOD]

2. Build a setup in 3.5 and install it on a fresh system. Then Build a setup (same product code and upgrade code) in 2009 express and try to install it:
Installation proceeds like there was no previous installtion. [BAD]

Any help is greatly appreciated. Thanks