PDA

View Full Version : Problem running silent install



etmarx
11-19-2008, 02:06 PM
Hi,

I am trying to run a silent installation of my product. I created a setup.iss successfully but when I run it using setup.exe -s a log is created with but my product is not installed. It finishes in about 1 second.

log:
[InstallShield Silent]
Version=v7.00
File=Log File
[ResponseResult]
ResultCode=0

Has anyone experienced a similar issue? Since I don't have an error in the log I'm not sure how to find the problem. Any suggestions would be greatly appreciated.

Thanks

NORTALF
11-19-2008, 02:27 PM
You have to specify response file for your install.

First from command line run something like this

C:\YourSetup.exe -r -f1"C:\YourResponseFile.iss"

Then to run it silently:

C:\YourSetup.exe -s -f1"C:\YourResponseFile.iss"


I use full path to YourSetup.exe and YourResponseFile.iss files

etmarx
11-19-2008, 02:33 PM
I am actually doing this already. I have the setup.iss in the same directory as the setup.exe and I have tried with -f1"dir/setup.iss" and without.

It is finding my setup.iss file because the log is being created. It just doesn't seem to be doing anything with it :(

Thanks for the tip though.

NORTALF
11-20-2008, 09:48 AM
Could be that you already have your app installed, then your dialogs are different and response file should be different. Try to check in add/remove programs if the app is already installed.