PDA

View Full Version : Error: Newer version is already installed



tfojvdl
11-18-2008, 05:24 AM
Hello,
I use InstallShield 2008 Professional and I am trying to build a basic MSI package that should upgrade an existing installation. The old install has version 6.00.00040 and the new installation has version 6.00.00041. Both installations have the same Upgrade Code.

When installing the new version on top of the old one the installation pops up with the message:

A newer version of this applcation is already installed on this PC. Please deinstall the newer version before installing this application.

I checked all settings I know of, but I don´t understand why 40 is newer than 41... Is this a bug in InstallShield?

Did someone observe the same in the past?
Is there any solution?

Thanks
Jürgen

P.S.: The First time we got this effekt was after a new installation of IS2008 on our build server using a licensing workaround proposed by the InstallShield support:

Hi Jürgen,

Thank you for contacting Acresso’s InstallShield Technical Support.

Does this issue only occur when you build from the command-line (and not when you build from the IDE)? If so, you have encountered a known issue with InstallShield 2008.

Please perform the following workaround:
1. Set the system clock ahead by 30 or more days.
2. Build from the command-line.
3. Reset the system clock to the original date.
4. Build from the command-line.

MichaelU
11-18-2008, 11:37 AM
The message you describe sounds like the major upgrade item designed to prevent downgrades. I'd suggest verifying that the item isn't hardcoded to an older version, and then examining a verbose log file. Look near the FindRelatedProducts action for clues.

tfojvdl
11-19-2008, 02:51 AM
Hello,
could you please describe more detailed, what I need to check? i do not understand your comment. I don´t want to downgrade at all. I just want to upgrade from 6.00.00040 to 6.00.00041, but for any unknown reason IS is handling that like a downgrade and i do not see why...

Thanks for your support.
Jürgen

tfojvdl
11-19-2008, 03:32 AM
Hello,
in addition I run an upgrade validation with the following result:

Validator: Val0003
Severity: Error
Message: The setup needs to perform a Major Upgrade of the previous setup specified.While upgrade table entries exist for the Upgrade Code, there is no upgrade table entry that matches the Product Version '6.00.00040' or Product Language '1033'.

I wonder if my upgrade settings are right. Could someone take a look at the screenshot?

Thanks
Jürgen

tfojvdl
11-19-2008, 03:59 AM
Even when I mention 6.00.00040 as former version that should be updated, i get the same error message:

While upgrade table entries exist for the Upgrade Code, there is no upgrade table entry that matches the Product Version '6.00.00040' or Product Language '1033'.

MichaelU
11-19-2008, 11:47 AM
I don't know how the settings on the ISPreventDowngrade major upgrade item were changed, but they are incorrect. If you create a new Basic MSI project, you can see it will have only a minimum set, and both include minimum and include maximum will be set to no.

If you want to properly upgrade from the previous version, you need to add a second major upgrade item which looks more like what your screenshot shows, although it should be Detect Only: No. The defaults on a new major upgrade item will likely be what you need.

tfojvdl
11-20-2008, 05:45 AM
Using the following settings allows me to install version 45 over 44, but also allows me to install 44 over 45 :-(


BR
Jürgen

tfojvdl
11-20-2008, 05:48 AM
using the following settings also allows me to install new version over old version, but when I want to install old version on new version, I get the Modify/Repair dialog :-(

Also the coomon page look strange, because it puts latest version number into "Minimum Field"

BR
Jürgen

tfojvdl
11-20-2008, 05:52 AM
When I create a new Major Update Item and select "Install over any previous" it brings the following settings and installation doesn´t work anymore. Installing NEW version OVER OLD gives: Newer Version already installed..."

I am pretty sure, that this is a bug in IS 2008 Professional.
Who can give me a config that allows to install new over old, but not old over new?

Maybe Macrovisoion/Acresso should debug....

Thanks
Jürgen

DebbieL
11-24-2008, 09:38 AM
In the Upgrades view, you should have two nodes under the Upgrade Windows Installer Setup node: (1) the ISPreventDowngrade node, which InstallShield adds by default, and (2) one that you must create for your upgrade. It sounds like you have modified the existing ISPreventDowngrade node instead of creating a new node. You'll want to restore the settings for the ISPreventDowngrade node (you can create a new project to see how the ISPreventDowngrade node is configured) and then add a new node for your upgrade.

The "Building MSI Updates and Patches" white paper on the following page may be helpful:
http://www.acresso.com/downloads/downloads_7481.htm

tfojvdl
12-03-2008, 06:44 AM
I followed your advice and that helped.
Thank you very much.
Jürgen