PDA

View Full Version : 1603 Fatal error during installation



kstan182
11-18-2008, 12:20 AM
Hi!

Could someone help me with this error I am getting.

When running the installation, I get the following 1603 Fatal error
7424

My verbrose log is as follows:

Property(S): ARPINSTALLLOCATION = C:\product\
Property(S): AdminUser = 1
Property(S): SystemLanguageID = 3081
Property(S): ProductLanguage = 1033
Property(S): CostingComplete = 1
Property(S): SOURCEDIR = C:\Documents and Settings\Administrator\Desktop\DISK1\
Property(S): SourcedirProduct = {5B52E414-5F9A-459F-A550-F4B53793EAEA}
Property(S): OutOfDiskSpace = 0
Property(S): OutOfNoRbDiskSpace = 0
Property(S): PrimaryVolumeSpaceAvailable = 0
Property(S): PrimaryVolumeSpaceRequired = 0
Property(S): PrimaryVolumeSpaceRemaining = 0
MSI (s) (48:C8) [17:12:12:578]: Note: 1: 1708
MSI (s) (48:C8) [17:12:12:578]: Product: product -- Installation operation failed.

MSI (s) (48:C8) [17:12:12:578]: Cleaning up uninstalled install packages, if any exist
MSI (s) (48:C8) [17:12:12:578]: MainEngineThread is returning 1603
MSI (s) (48:E4) [17:12:12:578]: Destroying RemoteAPI object.
MSI (s) (48:98) [17:12:12:578]: Custom Action Manager thread ending.
=== Logging stopped: 16/11/2008 17:12:12 ===
MSI (c) (F4:6C) [17:12:12:578]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (c) (F4:6C) [17:12:12:578]: MainEngineThread is returning 1603
=== Verbose logging stopped: 16/11/2008 17:12:12 ===

I read in another forum to look for "Return value 3" and to print that out, here it is:


Action start 17:12:11: InstallInitialize.
MSI (s) (48:C8) [17:12:11:890]: Doing action: ISXmlCosting
Action ended 17:12:11: InstallInitialize. Return value 1.
MSI (s) (48:14) [17:12:11:906]: Invoking remote custom action. DLL: C:\WINNT\Installer\MSI42.tmp, Entrypoint: ISXmlCosting
Action start 17:12:11: ISXmlCosting.
MSI (s) (48:C8) [17:12:12:390]: Machine policy value 'DisableRollback' is 0
MSI (s) (48:C8) [17:12:12:390]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
Action ended 17:12:12: ISXmlCosting. Return value 3.
MSI (s) (48:C8) [17:12:12:390]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (48:C8) [17:12:12:390]: Unlocking Server
Action ended 17:12:12: INSTALL. Return value 3.


Has anyone experienced the same error? or can tell me what may be causing this and steps on how to fix it?:confused:

Thanks!

I am using Installshield 2008 Professional Edition Version 14

kstan182
11-18-2008, 07:48 PM
when I analyze the log this is what I get
7425

kstan182
11-21-2008, 01:26 AM
Found the problem.:)

It was quite bizarre. A file within System Configuration > XML File Changes was causing the problem.

I deleted the XML and re-imported it and the error went away.

The new imported XML is identical to what it was before. :confused:

just glad its working now :)

sturge
02-11-2009, 09:04 AM
Thanks! I had this exact same error. Curious how this happened.

EDIT
Turns out I had changed the location of the files it was associated with. The xml file was still pointing to the old location in the XML File Changes screen.