PDA

View Full Version : Error 1155: Cannot find [PRODUCT NAME].msi



TimKitch
08-01-2008, 09:41 AM
InstallShield 2009 SP1

I'm using a Basic MSI project set to release into a single Setup executable. This runs fine on XP/Vista 32-bit, but on Windows Vista Ultimate x64 Edition it errors: I get a 1155 [Temp folder]\[GUID]\[Product Name].msi File not found error.

If I navigate to that directory in Explorer before clicking OK to the error dialog, the .msi file is there, and running it installs the application as expected.

I've tried running setup.exe with the /debuglog parameter to see what's happening - but it installs fine and does not error :mad:

Would I be correct that assuming this is some-kind of bug with InstallShield or is there a simple workaround?

Any suggestions are gratefully received.

Kindest regards,

Tim

TimKitch
08-01-2008, 10:04 AM
UPDATE

Not sure how I missed it last time, but I think I've found the cause of the error - At the beginning of the [product name].msi in the Temp folder there is a strange character (similar to รณ). Could this be an ANSI/Unicode discrepancy.

Any suggestions welcome.

RobertDickau
08-01-2008, 10:22 AM
Please see if this thread is related.

TimKitch
08-01-2008, 10:54 AM
Thanks - that thread describes the exact same issue - solution has worked fine.

Apologies for the double-post.