PDA

View Full Version : Help Please - Install Condition



ronanorm
07-28-2008, 05:25 PM
Hello,

I am a newbie to building installers. I have a project for installing a video driver. The product if working but now I am trying to add a few custom conditions and am having issues. I think it is simple, I just don’t know what I am doing.
What I need:
What do I need to do to look for a Registry key “HKLM\Software\NVIDIA Coportation” and if it exists I want the install to stop..
That’s it, seems simple but I am getting confused if I should be able to write a Exec Condition or do I need to…
Any help would be great.

Ron - HP

RobertDickau
07-28-2008, 05:42 PM
The System Search Wizard will help you set up a check whether a registry value exists (I'm not sure MSI supports just the existence of a registry key). The "search" will store the contents of the registry value in a property you specify (such as FOUND_IT).

The end of the wizard also lets you specify whether to use the results of the search in an install condition, which is a condition tested before the installer really gets going. In your case, you might want to reverse the condition from the default FOUND_IT to Not FOUND_IT, and then provide a message to display if the condition fails.

ronanorm
07-28-2008, 06:02 PM
Thanks for the fast reply.

So are you saying that going through the search wisard and selecting to have it be a condition at the end is all I need to do? I dont need to tie it in anywhere else?

Whould it be better is I provided Key and value to check?

Ron

RobertDickau
07-28-2008, 06:13 PM
That should do it; the System Search Wizard will prompt you for the key and value to test for, and whether to get an install condition involved, and that should be that.

ronanorm
07-29-2008, 05:50 AM
Thanks Robert.. Was making it more complex than it needed to be.. That worked, and it did let me use a Key with no value.

hmorales
03-07-2009, 01:16 PM
That should do it; the System Search Wizard will prompt you for the key and value to test for, and whether to get an install condition involved, and that should be that.

Hello Robert, I am also new to Installshield (just installed 2009 profesional version) and I am getting crazy here. I need something similar, just the opposite (the normal situation I suppose): Test for the existence of a registry key, but supringsinly enough is not working (at least not sure where the problem might be). The install just stops there; of course if I change the condition to : NOT SOFTWARE_TIMBERLINE it goes on.

On purpose I created 2 other DUMMIES properties (not install conditions), one (DUMMY_THAT_EXISTS) that maps to another sublevel of the registry path and a third one that i am sure does not exists at all (DUMMY_PROPERTY)

I am not sure how to read the log but what I observed is that that DUMMY_PROPERTY is showing the full registry key (assuming that it does that whenever does not find it) whereas the others not (the install condition and the DUMMY_THAT_EXISTS)... so, my guess is that the registry is being found but not sure what is evaluating to false in the install condition.

A portion of the log is: (The message of my install condition is "This condition has evaluate to FALSE so install won't continue" - so it can be identified below)

------


Action 9:30:24: AppSearch. Searching for installed applications
Action start 9:30:24: AppSearch.
AppSearch: Property: SOFTWARE_TIMBERLINE, Signature: NewSignature1
MSI (c) (C4:F0) [09:30:24:487]: Note: 1: 2262 2: Signature 3: -2147287038
AppSearch: Property: DUMMY_PROPERTY, Signature: NewSignature11
MSI (c) (C4:F0) [09:30:24:487]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (c) (C4:F0) [09:30:24:487]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\THIS_WONT_EXISTS 3: 2
AppSearch: Property: DUMMY_THAT_EXISTS, Signature: NewSignature12
MSI (c) (C4:F0) [09:30:24:487]: Note: 1: 2262 2: Signature 3: -2147287038
Action ended 9:30:24: AppSearch. Return value 1.
MSI (c) (C4:F0) [09:30:24:487]: Doing action: LaunchConditions
Action 9:30:24: LaunchConditions. Evaluating launch conditions
Action start 9:30:24: LaunchConditions.
Info 2898.For Tahoma8 textstyle, the system created a 'Tahoma' font, in 0 character set.
This condition has evaluate to FALSE so install won't continue
MSI (c) (C4:F0) [09:30:25:918]: Product: TestSetup -- This condition has evaluate to FALSE so install won't continue

Action ended 9:30:25: LaunchConditions. Return value 3.


----

My conditions:

SOFTWARE_TIMBERLINE | This condition has evaluated to FALSE so install won't continue

if I change it to

NOT SOFTWARE_TIMBERLINE | This condition has evaluated to FALSE so install won't continue

it would work..
I will appreciate any prompt input (I am running behind schedule! :( )