View Full Version : lc_set_attr and lmutil lmpath -status

07-24-2008, 01:21 PM
We are primarily using Trusted Storage, but need to use license files to support dongles. We have designated ..\documents and settings\all users\application data\<company>\<product>\common\license as our license file directory.

The following call succeeds (szLicDir is set as above):
nRC = lc_set_attr(lm_job, LM_A_LICENSE_DEFAULT, (LM_A_VAL_TYPE)szLicDir);

...but the subsequent call to lc_checkout fails (-1). If I check the paths for my vendor daemon using 'lmutil lmpath -status' the path does not show up. If I manually use lmutil lmpath -override <vendor> to set the path, then lc_checkout succeeds. Am I formatting my search string incorrectly?

Diagnostic dump below:

[4212] { 5164} Server Runtime : Initializing FLEX license path to C:\Documents and Settings\All Users\Application Data\Kepware\common\License\;.


[4212] { 4020} Server Runtime : Checkout of feature [KEPServerEX_V5], version [2008.07] failed. Error=[Cannot find license file.
[4212] The license files (or license server system network addresses) attempted are
[4212] listed below. Use LM_LICENSE_FILE to use a different license file,
[4212] or contact your software provider for a license file.
[4212] Feature: KEPServerEX_V5
[4212] Filename: *.lic
[4212] License path: c:\flex;C:\Documents and Settings\All Users\Application Data\Kepware\common\License\;*.lic;
[4212] FLEXnet Licensing error:-1,35

07-25-2008, 09:22 AM
As a test, does it make a difference if you omit the trailing backslash in that part of the path?


07-25-2008, 09:51 AM
Yes, that was the problem, thanks again.