PDA

View Full Version : Install .net Framework 2.0



jayakumarn
07-24-2008, 06:38 AM
:confused: Hi All,
I would like to install the .net framewrok 2.0 in the target machine if it is not present in the target ...
i would like to do it by using Installshield 2009?
please suggest me step by step...:rolleyes:

I am confused with prq and redistributable. pls begin wiith basic......

Regards,
Jayakumar Natarajan
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

DebbieL
07-24-2008, 08:04 AM
Which project type are you using? If you're using a Basic MSI or InstallScript MSI project, you'd add the 32-bit version of the .NET Framework 2.0 to your project through the Release Wizard or the .NET/J# tab in the Releases view.

The following help topic has an overview of how to add .NET, depending on what project type you're using and which version of .NET you need:
Adding .NET Framework Redistributables to Projects (http://helpnet.acresso.com/Robo/BIN/Robo.dll?tpc=/robo/projects/installshield15helplib/NetRedistAdd.htm)

jayakumarn
07-24-2008, 08:24 AM
just specifying the version as in release wizard is enough or want to do any other thing....
like adding the .net framework 2.0 with setup.....

plese suggest me....

Regards
Jayakumar Natarajan

DebbieL
07-24-2008, 08:32 AM
Specifying the the version in the Release Wizard should be enough. When you do that, the .NET Framework will be installed if it is not present on the target system.

jayakumarn
07-24-2008, 08:51 AM
Thanku very much for your kind reply...
but i am able to see only version 1.0,1.1,2.0
what to do if i want to install framework 3.0 or later

Regards,
Jayakumar Natarajan
Ever Tried Ever Failed No Matter, Try again Fail Again Fail Better.

jayakumarn
07-24-2008, 09:26 AM
Hi ,:D
While releasing the project the resultant exe will call only msi file.....
In my project I am using multilanguage support , but multilanguage is not supported in msi File its support only in exe file.....
Here we are getting exe file which calls the MSI file.... so unable to get teh multillanguage support...
Please suggest me !!!


Regards
Jayakumar Natarajan
Ever Tried Ever Failed No Matter, Try Again Fail Again Fail Beter.

DebbieL
07-24-2008, 10:38 AM
.NET Framework 3.5, 3.0 SP1, 3.0, and 2.0 SP1 are available as InstallShield prerequisites. You can add one or more of these prerequisites to your project by selecting the appropriate check boxes in the Redistributables view. Please see the following help topic for more details:
Including the Microsoft .NET Framework and Microsoft .NET Framework Language Pack Prerequisites (http://helpnet.acresso.com/Robo/BIN/Robo.dll?tpc=/robo/projects/installshield15helplib/NetFrameworkPrereq.htm)