PDA

View Full Version : Feature installs even when un ticked



RICOUK
07-23-2008, 10:54 AM
Hi

I have a feature which is associated to one component. The component installs whether the feature is selected or not.

If I associate another component to the feature and un tick the feature, the second component does not install but the first one still does. Both features are set up the same, except files.

The only way to stop the component from installing is excluding it from the build itself, which obviously is not acceptable. 90% of the time the feature won't be installed which makes the problem worse.

Any ideas would be appreciated.

Thanks,
Rich

ggrewe
07-23-2008, 11:33 AM
Look at the value of INSTALLLEVEL in Property Manager and change the INSTALLLEVEL of this feature to be something higher than that of what is in Property Manager.

RICOUK
07-24-2008, 03:44 AM
Thanks, INSTALLLEVEL wasn't actually in the Property Manager. Adding it and making sure the feature is higher did not help. It wouldn't make sense either as all the features are set as 1 and they only install if they are ticked. Also wouldn't explain why only one component installs whatever, no matter which feature it is assigned to.

The component is set up the same as all the others. I have written some installscript which uses the component, however, it only runs if the files are present, which is all the time at the moment! There is no code to force it to install, not that I am aware of anyway.

Thanks,
Rich

RICOUK
07-28-2008, 06:30 AM
No one have any ideas? It is quite annoying now, I have re-added the component and feature and assigned the component to a different feature and tried that, the component always installs, no matter what.

Is there something in IS that if file changes are made in installscript it installs that component or something stupid like that?

Thanks,
Rich

Abdeyman
07-29-2008, 02:05 PM
I had a similar problem a few weeks ago. Files in an unselected feature were installing when they weren't supposed to.

My problem was with the ".Net Scan at Build" setting "Dependencies and Properties". When I changed the setting to "Properties Only", the files were no longer installed.

Scott

RICOUK
07-30-2008, 03:53 AM
Thanks, unfortuently, this didn't work, even setting it to None did nothing. It keeps installing the files. When I untick the feature the disk space required drops appropriately so that far is correct, something is forcing it to be installed and I don't what it is!

Thanks again,
Rich