PDA

View Full Version : BasicMSI + Installer Class = Not Firing All Events



GameComm
07-17-2008, 10:53 AM
I've been having some issues with our installer not uninstalling correctly. Among these issues are:
1) If uninstalling after an upgrade, the program is "uninstalled" according to windows, but none of the files are removed
2) During any uninstall, *none* of the System.Configuration.Install.Installer class events are fired. This is strange to me given that it works fine in a normal MSI build through Visual Studio (without any installshield involved), and I believe worked fine in IS2008. For me, this is a problem because I can't reverse any of the system changes I make in the same installer classes's Install event calls which *do* work.

Any ideas? I've seen some related posts to both of these, but none of them seem very "resolved" (and I question how similar the conditions are to my situation). One of the posts said something about an /uninst parameter, but with no information on where it goes, when it will be used there, or why it should even be necessary.

Christopher Painter
07-17-2008, 11:16 AM
I do not suggest using Installer class Custom actions under *ANY* ( yes, I mean any ) circumstances. Check out WiX DTF instead. It is a much better solution that will give you the ultimate control over what your custom actions can and can't do while having much better reliability and simplified integration.

RobertDickau
07-17-2008, 01:42 PM
For what it's worth, InstallShield 2009 also has managed-code custom actions as an alternative to Installer classes; and I think the /uninst switch is only for InstallScript projects.