PDA

View Full Version : error occurred streaming splashscreen bitmap



ggrewe
07-16-2008, 08:21 AM
Hello,

I am using InstallShield 2009 and receiving the following error message when my MSI compiles;

ISDEV : error -6003: An error occurred streaming 'bitmap name' into setup.exe

This file is the bitmap we are using for a splashscreen. I have had our marketing department recreate the bitmap several times. After reading the log file for the build, there is no better information.

Any help is greatly aprpeciated.

Mike Marino
07-16-2008, 12:02 PM
Are you trying to pull the file in from a network drive?

ggrewe
07-16-2008, 12:54 PM
No Mike, it is a local drive, just a different folder.

Mike Marino
07-16-2008, 01:00 PM
Can you post what the path is?

ggrewe
07-16-2008, 01:09 PM
Sure, here is the complete error line...

ISDEV : warning -6607: Your splash screen will not be displayed during the installation because D:\ILEADS_support_82\Splashscreen40\ILEADS.bmp is not a bitmap file. To display a splash screen, you must specify a valid bitmap file.

I am not sure what it is looking for. The bitmap is 493 x 302 and is only 582kb in size.

Mike Marino
07-16-2008, 01:11 PM
Can you send me the file:

mmarino@acresso.com

We have seen problems with bitmaps when the the bitmap header information is not correct (some paint programs seem to write this info better than others.)

RobertDickau
07-16-2008, 01:17 PM
An issue that used to come up (may not be true nowadays) is that run-length-encoded bitmaps and bitmaps with alpha channels can't be displayed; the rule seemed to be that if you could view and save the bitmap using MS Paint, it could be displayed as a splash screen...

Mike Marino
07-16-2008, 05:19 PM
I resolved this issue by opening the user's file up in a paint program and re-saving it.

Re-creating the file seemed to fix the issue for the user.