PDA

View Full Version : InstallShield 2009 SP1 Updates



esiemiat
06-30-2008, 03:44 PM
Where can I get updated copies of the SAB abd MSI Tools for 2009 SP1? The article http://kb.acresso.com/selfservice/documentLink.do?externalID=Q200241 has the following to say about this, but all I get for updates is the MSI InstallScript Objects.



To obtain the updated Standalone Build:
An updated version of the Standalone Build is now available as a full installation (not as a patch); you must uninstall the earlier version of the InstallShield 2009 Standalone Build before installing this new version. To obtain the installation for the updated version of the Standalone Build, check for updates from within InstallShield.

To obtain the updated installation of the InstallShield MSI tools:
An updated version of the separate Premier-only installation for the InstallShield MSI tools (InstallShield MSI Diff, InstallShield MSI Query, InstallShield MSI Sleuth, and InstallShield MSI Grep) is now available as a full installation (not as a patch); you must uninstall the earlier version before installing this new version. To obtain the installation for the updated version of these tools, check for updates from within InstallShield.

esiemiat
06-30-2008, 03:53 PM
Sorry, I forgot to mention that I am a Premier user, and that I checked for updates from within InstallShield and was informed that there were none.

schmoli
06-30-2008, 04:22 PM
Odd, you're not trying from a evaluation version are you? I just upgraded to 2009 today and immediately after installing SP1 I noticed it in the updates list. I suppose that doesn't help you too much, but at least it proves that's where it' supposed to be.

http://xs328.xs.to/xs328/08271/2009sab688.jpg

esiemiat
06-30-2008, 05:38 PM
Thanks. Your poist made me realize I had to unhide the updates. However, I notice that the updates do not indicate SP1 and show that they were posted back in May. I downloaded them anyway, and they are different from the original files, but are they the SP1 versions?

SherylSikora
06-30-2008, 05:52 PM
Yes they should be the SP1 versions. You can verify this by checking the file versions of the following files:

For SAB: ISWIBuild.dll should be 15.0.0.533
For MSI Tools: MsiGrep.exe should also be 15.0.0.533.

esiemiat
07-01-2008, 07:54 AM
Thank you for your help.