PDA

View Full Version : 1155 Error on Basic MSI with Setup.EXE



LanceRas
06-18-2008, 12:09 PM
Any ideas on why a few customers with Vista would be getting a 1155 Error in a Basic MSI project using the Setup.EXE.

The error appears to occur when the stub is trying to launch the actual MSI. So even when trying to pass the comand line parameters to create a log, it doesn't even get that far.

In IS2008, there is no problem.

I had done two things different. In the project, I switched to the new Unicode stub. The other was I changed the compression to maximum in the Settings.XML.

I have Create Install Launcher supporting Do Not Install Windows Installer. MSI Engine Version is set to 3.1 or 2.0 Best Fit. On a system we had remoted to, they had 4.0 on their Vista. We even tried upgrading them to MSI 4.5 redist just to see.

No errors during the build that are different, per say.

I'm trying to find a pattern in the customer OS's. I have Business X64 Vista on SP 1 and can't duplicate. I've cleared my temp folder to make sure I wasn't cacheing anything.

I'm using automation to make the build from a different tool. This too has worked in past, so I can't see where cause.

At this point, I've made two builds via the IDE. One using the Unicode stub, then one with the Ansi. I'm waiting for word on if this may resolve the issue or if both work.

Suggestions welcome.

LanceRas
06-18-2008, 02:41 PM
Apparently, the ANSI worked on a system exhibiting this behaviour and did not under the Unicode.

LanceRas
06-18-2008, 04:25 PM
Interesting. So far has been Vista Home Editions as well as they are also running Norton Internet Security.

LanceRas
06-18-2008, 05:36 PM
Submitted as IS Case Number 71465

We hit a Vista install that was using AOL/McAffe so that isolated, I think, Norton from the effect.

DebbieL
06-19-2008, 08:02 AM
Is your release a compressed Setup.exe file?

If so, perhaps the issue that you encountered is related to the one described in the following thread:
http://community.acresso.com/showthread.php?t=181571

Debbie Landers
Acresso Software

LanceRas
06-19-2008, 12:33 PM
Debbie,

yep.... Somehow missed that.