PDA

View Full Version : patchwiz.dll questions



Holger_G
06-13-2008, 05:30 AM
Hi all,

I noticed that IS 2009 includes patchwiz.dll v3.1.4000.2049.

1) Which version of patchwiz.dll is recommended to use? Using IS to create patches.

2) Can I simply exchange the patchwiz.dll in the IS2008\System folder with the recent patchwiz.dll v4.5.6001.22192 from the Windows Installer 4.5 SDK?


Holger

joshstechnij
06-13-2008, 11:41 AM
We ship patchwiz 3.1 with InstallShield as our internal testing seems to indicate that patches built with patchwiz 4.5 do not run on machines with MSI 2.0 installed. If this is not an issue for you, you can replace patchwiz.dll in the System folder with the 4.5 version. You may also want to replace mspatchc.dll with the one included in the MSI 4.5 SDK. Note that we would recommend making backup copies of the original files.