PDA

View Full Version : Crash link project msvcr80.dll - installshield 2009



Boulenger Danie
06-12-2008, 12:01 PM
Hi,
I have a crash when I build my project , i have update msi 4.5 (beta 2 ) to 4.5 release , but the bug still here...

AppName: isdev.exe AppVer: 15.0.0.498 ModName: msvcr80.dll
ModVer: 8.0.50727.1433 Offset: 00008aa0

I have try to update mfc dll : no effect...

For more information , the output windows in attached fille "2821_appcompat.txt".

crash on visual studio 2005 debug :

AFX_STATIC_DATA const _PNH _pfnUninitialized = (_PNH)-1;

void* __cdecl operator new(size_t nSize)
{
void* pResult;
#ifdef _AFXDLL
_PNH pfnNewHandler = _pfnUninitialized;
#endif
for (;;)
{
#if !defined(_AFX_NO_DEBUG_CRT) && defined(_DEBUG)
pResult = _malloc_dbg(nSize, _NORMAL_BLOCK, NULL, 0);
#else
pResult = malloc(nSize); HERE ( nSize == 0x00f08590 ) ...
#endif
if (pResult != NULL)
return pResult;

#ifdef _AFXDLL
if (pfnNewHandler == _pfnUninitialized)
{
AFX_MODULE_THREAD_STATE* pState = AfxGetModuleThreadState();
pfnNewHandler = pState->m_pfnNewHandler;
}
if (pfnNewHandler == NULL || (*pfnNewHandler)(nSize) == 0)
break;
#else
if (_afxNewHandler == NULL || (*_afxNewHandler)(nSize) == 0)
break;
#endif




Output microsoft visual studio 2005 :

'isdev.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.VC80.ATL_1fc8b3b9a1e18e3b_8.0.50727.762_x-ww_cbb27474\ATL80.dll', Symbols loaded.
'isdev.exe': Loaded 'C:\WINDOWS\system32\msxml4.dll', No symbols loaded.
'isdev.exe': Loaded 'C:\Program Files\InstallShield\2009\System\isupgrade.dll', No symbols loaded.
'isdev.exe': Loaded 'C:\Program Files\Fichiers communs\Microsoft Shared\OFFICE11\MSOXMLMF.DLL', No symbols loaded.
'isdev.exe': Loaded 'C:\Program Files\InstallShield\2009\System\IsWsInstallScripts.ocx', No symbols loaded.
'isdev.exe': Loaded 'C:\Program Files\InstallShield\2009\System\ISScriptEditor.ocx', No symbols loaded.
'isdev.exe': Loaded 'C:\Program Files\InstallShield\2009\System\CmnUI.dll', No symbols loaded.
'isdev.exe': Loaded 'C:\Program Files\InstallShield\2009\System\ScriptUI.dll', No symbols loaded.
'isdev.exe': Loaded 'C:\Program Files\InstallShield\2009\System\ISBuildStringTables.dll', No symbols loaded.
'isdev.exe': Loaded 'C:\Program Files\InstallShield\2009\System\ISWIBuild.dll', No symbols loaded.
'isdev.exe': Loaded 'C:\Program Files\InstallShield\2009\System\Build.dll', No symbols loaded.
'isdev.exe': Loaded 'C:\Program Files\InstallShield\2009\System\BECommonLib8.dll', No symbols loaded.
'isdev.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.VC80.MFC_1fc8b3b9a1e18e3b_8.0.50727.762_x-ww_3bf8fa05\mfc80u.dll', Symbols loaded.
The thread 'Win32 Thread' (0xa30) has exited with code 0 (0x0).
Microsoft Visual Studio C Runtime Library has detected a fatal error in isdev.exe.

Press Break to debug the program or Continue to terminate the program.
The thread 'Win32 Thread' (0x994) has exited with code -1073741811 (0xc000000d).
The thread 'Win32 Thread' (0xc28) has exited with code -1073741811 (0xc000000d).
The thread 'Win32 Thread' (0x434) has exited with code -1073741811 (0xc000000d).
The thread 'Win32 Thread' (0xcc0) has exited with code -1073741811 (0xc000000d).
The thread 'Win32 Thread' (0x9a4) has exited with code -1073741811 (0xc000000d).
The thread 'Win32 Thread' (0x104) has exited with code -1073741811 (0xc000000d).
The thread 'Win32 Thread' (0x740) has exited with code -1073741811 (0xc000000d).
The thread 'Win32 Thread' (0xec0) has exited with code -1073741811 (0xc000000d).
The thread 'Win32 Thread' (0x8d0) has exited with code -1073741811 (0xc000000d).
The thread 'Win32 Thread' (0x37c) has exited with code -1073741811 (0xc000000d).
The thread 'Win32 Thread' (0xd10) has exited with code -1073741811 (0xc000000d).
The program '[2688] isdev.exe: Native' has exited with code -1073741811 (0xc000000d).

Thanks for your help !

Regards.

joshstechnij
06-12-2008, 03:23 PM
Can you provide some further information:
- What project type are you working with (Basic MSI, InstallScript MSI, merge module, InstallScript, etc.)?
- Can you reproduce this with other projects or a sample project?
- Are you building your project through the Visual Studio integration, or are you building with the InstallShield IDE?
- Can you try building with the command line build to create a verbose build log:
iscmdbld.exe -p "C:\PathToProject\Project.ism" -a "<Product Configuration>" -r "<Release>" -v

Where <Product Configuration> and <Release> are the product configuration and release names in the project you are building. Please attach the log file.

Boulenger Danie
06-13-2008, 03:36 AM
Hi joshstechnij,
I'm working with installscript project.
I Can reproduce this with one other project , problem looks the same about msvcr80.dll...

Project was converted from installshield 6.22 to installshield 2009 with success.

Result for command line :

"C:\Program Files\InstallShield\2009\System\IsCmdBld.exe" -p "C:\InstallShield 2009 Projects\MapWeb2.2unicode\MapWeb2.2unicode.ism" -r "mapwebdev2_2" -v > Buildlog_mapwebdev2_2.txt

-> empty file ( no warnings no errors...)

I'm building with the InstallShield IDE.( problem is similar when I use Visual Studio 2005 builder).


Regards.

Boulenger Danie
06-16-2008, 05:50 AM
I would like to specify some supplementary information :

The problem is specific from Installshield version 15 (2009) because migration project from 6.2 to Installshield v 12 and v 14 runs successfuly.

Regards.

joshstechnij
06-16-2008, 12:42 PM
Can you send me your project (ISM and .rul files) that reproduces this behavior:
joshs@acresso.com

Boulenger Danie
06-17-2008, 05:14 AM
Files were sent to joshs@acresso.com .

joshstechnij
06-17-2008, 12:14 PM
Thanks for sending your project!

I was able to reproduce the behavior with the project and track down where the build was crashing. We should have a fix available for this issue in the near future.

Boulenger Danie
06-20-2008, 02:05 AM
It works , thanks.

RICOUK
06-20-2008, 05:05 AM
I also have this problem on one of our projects that have been converted from 2008 projects to 2009, one works and builds fine, the other crashes isdev.exe.

Boulenger, what did you do to make it work?

Thanks
Rich

Mike Marino
06-20-2008, 09:53 PM
We just released IS2009 SP1 which corrects this issue. Go to the Tools menus and select Check for Updates to get the patch.

The English patch was released today. German and Japanese will be available early next week.

RICOUK
06-23-2008, 08:39 AM
Great, thanks, it worked, both projects build now.

nicolebarge23
06-24-2008, 06:57 AM
hello,

I have the same error than BOULENGER DANIE, but I don't understand the answers to resolve the problem...

Can you explicite more the answers please ???


What is IS2009 SP1 ????
I'm using Visual Studio 6 for my application and i don't see where I can "Check for Updates"

DebbieL
06-24-2008, 07:47 AM
IS2009 SP1 is InstallShield 2009 Service Pack 1. The Check for Updates command is available from the Tools menu within InstallShield. If you're using InstallShield from within Visual Studio, I think that one of the InstallShield toolbars has a Check for Updates button. Checking for updates through one of these methods launches FLEXnet Connect's Software Manager, which will check to see if any updates for your version of InstallShield are available; if any are available, you can download and install them from within the Software Manager.

Or, as another alternative, you can download the SP1 patch directly from the following KB article:
http://kb.acresso.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=Q200241
(A link to this KB article is also available in the Read Me First sticky at the top of this forum.)

Debbie Landers
Acresso Software

megha_3781
10-17-2008, 05:15 AM
Hi, I have IS 2009 Premier. We have an Installscipt project made in IS2008.
Recently I converted to 2009. Whenever I try to make a build, it crashes.
If I remove Crystal Reports 8.5 object and make build it will not crash.

What I tried is I opened new project (Installscript) and added only Crystal Reports 8.5 then also it crashed.
I opened a new project Installscript MSI and did the same thing it didn't crash.

I installed the IS 2009 again in new system. Looks like there is some problem with the IS 2009 Premier version.

I have posted the error logs here..

http://community.acresso.com/showthread.php?p=427016#post427016 (http://community.acresso.com/showthread.php?p=427016#post427016)

Mike Marino
10-17-2008, 09:23 AM
Do you have IS2009 SP2?

megha_3781
10-18-2008, 12:55 PM
Yes I have Service Pack 2.