PDA

View Full Version : Compressed setup.exe extracts garbled msi filename on vista



Mattmull
06-12-2008, 08:58 AM
Hi,

I'm using IS2009 Pro, and I'm stuck trying to figure this out. When I do a non compressed setup, everything works fine under Vista. When I run a compressed setup.exe, it works fine on XP and 2000, but on Vista, the extracted MSI file gets a garbage character prefixed on the front of its name, so the installer fails because it can't find the msi filename.

The really weird thing is, if I run setup with /debuglog, the problem goes away and the file gets extracted without the garbage character prefixed.

Anyone know what this could possibly be?

Thanks

DLee65
06-12-2008, 09:32 AM
Just a thought, I noticed a feature in the release settings that allows you to support ANSI or UNICODE. Some operating systems do not support the wide character format out of the box and and could lead to garbled characters, at least that is my understanding of the problem.

In release settings see the Setup tab. See the option for Setup Type Launcher. The options are ANSI or UNICODE.


Specify the type of setup launcher that you want InstallShield to create at build time:

Unicode—A Unicode setup launcher can correctly display double-byte characters in the setup launcher dialogs, such as the PreparingToInstall dialog, regardless of whether the target system is running the appropriate code page for the double-byte-character language. Windows 9x does not support Unicode setup launchers.
ANSI—An ANSI setup launcher displays double-byte characters in the setup launcher dialogs if the target system is running the appropriate code page. However, it displays garbled characters instead of double-byte characters in those dialogs if the target system is not running the appropriate code page.
For more information on setup launchers, see Creating a Setup Launcher.


I am not sure if this is the problem you are facing, but it was the only idea I could think of off the top of my head.

Mattmull
06-12-2008, 09:46 AM
Thanks! That fixed it...strange error though, isn't Vista fully supposed to fully support UNICODE?

joshstechnij
06-12-2008, 12:34 PM
I am able to reproduce this behavior. Since Vista is a Unicode operating system, there shouldn't be any reason this would fail.

I'll post more information here after we're able to figure out why this is failing on Vista.

LanceRas
06-19-2008, 01:07 PM
I haven't been able to repro, but I've hit a few Vista installs with the problem. So far, looks like with Home edition. Most had Norton on it, but we hit one with McAffee.

Agree this is weird and agree that Vista is a Unicode OS, so that should not make a difference.

Now Vista is Unicode 5.0 but I think XP and 2K are 4.x. So I wonder if that is part of the problem.

joshstechnij
06-19-2008, 01:21 PM
Can you try building your projects with the attached updated setup.exe's (extract the zip file to C:\Program Files\InstallShield\2009\Redist\Language Independent\i386; make a backup copy of setup.exe, setupW.exe, setupPrereq.exe, and setupPrereqW.exe).

Please let me know if this helps.

LanceRas
06-19-2008, 02:59 PM
I don't have a system in house exhibiting this issue, however, the progress which showed Extracting: xxx and Decompressing: xxxx is now visible where previously it just showed : xxxx.

I'll make rebuilds and monitor situation.

Mike Marino
06-20-2008, 09:57 PM
We just released IS2009 SP1 which corrects this issue. Go to the Tools menus and select Check for Updates to get the patch.

The English patch was released today. German and Japanese will be available early next week.