PDA

View Full Version : IS2009 crashes while building a 2008 project



Brandon Lowe
06-10-2008, 04:43 PM
I have installed 2009 and I made a copy of one of my installs from 2008. This install is built every other day here so I now it works great in 2008. It was created in IS 7 and has migrated up to 10, 11, 2008 and now 2009. When I try to build in 2009 the build runs for about 20 seconds and then I get a hard error and my options are to see the info or close the IDE. So at this point it is not looking good for 2009. I have attached a doc with screen shots of the error.

Thanks
Brandon

hidenori
06-10-2008, 06:10 PM
Could you post a verbose log for the build that can be produced by the following command line?

C:> <System>\IsCmdBld.exe -p "Your Project File Path" -v

The <System> directory is by default found in this path <C:\Program Files\InstallShield\2009\System>.

Thank you for your patience and cooperation.

Brandon Lowe
06-11-2008, 10:20 AM
Here is my command line I used. I'm not sure if the -v is in the right place but it did look like I was getting more infor on the screen. Where will this log file be written? I looked in the normal log and reports directories and there is nothing there.


"C:\Program Files\InstallShield\2009\System\IsCmdBld.exe" -p "I:\ISPro\Development test\IS2009\5.0 Server\5.0 Server.ism" -r "Test" -v

hidenori
06-11-2008, 10:53 AM
The build log file should be created under the <ISProjectFolder>\Your Product Configuration\Your Release\Log Files folder. If you cannot find it, you can write the console output to a text file as follows:


"C:\Program Files\InstallShield\2009\System\IsCmdBld.exe" -p "I:\ISPro\Development test\IS2009\5.0 Server\5.0 Server.ism" -r "Test" -v > C:\Buildlog.txt

Brandon Lowe
06-11-2008, 11:25 AM
I tried that already and it creates the file but it is blank. Ok I ran it and took screen shots of the info displayed. Hope this helps.

Brandon

hidenori
06-11-2008, 11:55 AM
Thank you for posting the screenshot. Unfortunatly, it does not give much information for us to narrow down the crash. Would it be possible for you to email me your ism project and InstallScript files at hyamanishi@acresso.com?

Thanks again for your cooperation.

Brandon Lowe
06-11-2008, 04:26 PM
I sent a zip of the file to support through the incident I opened.

Brandon Lowe
06-18-2008, 11:58 AM
I got an email from support about my crashing after converting a project from 2008 to 2009 and the answer was as follows

It would seem that this crashing issue is a known issue that we're looking to fixing down the line. For a temporary workaround, can you try taking any of your components that use subfolders, and try separating them into different components?

So it is a known issue. I know 2008 did not have the issue. It is a new issue if you ask me. I have about 20 different installs I maintain and they all have sub folders in them. For now 2009 is not going to work and if the issue is not fixed soon I may be done upgrading my installshield.

Michael Forshaw
06-18-2008, 12:36 PM
What type of project is this - InstallScript or MSI?

Does it matter if the components are dynamic or static?

If possible could you post an example screenshot of the component layout because if it is what I suspect this is a HUGE bug.

What does "fixing down the line" mean? I think we will be cancelling our maintenance contract if they suggest that workaround to us.

joshstechnij
06-18-2008, 01:14 PM
This issue affects InstallScript projects using component subfolders (these subfolders need to have been created in a certain manner and would need to be more than one level deep). Please try building with the InstallScript PrjMgr.dll build DLL available in the following thread if you are seeing this issue:
http://community.acresso.com/showthread.php?t=181629

Brandon Lowe
06-19-2008, 01:10 PM
Ok I downloaded the PrjMgr.dll file and was able to build my project. I will now test my other project to make sure they work too.
Thank you for posting a fix so fast.

Brandon

Mike Marino
06-20-2008, 09:58 PM
We just released IS2009 SP1 which corrects this issue. Go to the Tools menus and select Check for Updates to get the patch.

The English patch was released today. German and Japanese will be available early next week.