PDA

View Full Version : MSI 4.5 distribution



nitsev
06-10-2008, 08:00 AM
Release notes says IS 2009 support MSI 4.5 BETA. Also, in the releases view it's not possible to select MSI 4.5 under the property MSI Engine Version

First, what does BETA support mean? Will it work with the final MSI 4.5 (which was released before IS 2009 btw)

Second, if I cannot select MSI 4.5 as the MSI engine to use, how am I supposed to take advantage of features like chaining installs etc? Do I have to include MSI 4.5 as a setup prerequisite in that case?

hidenori
06-10-2008, 08:52 AM
Release notes says IS 2009 support MSI 4.5 BETA. Also, in the releases view it's not possible to select MSI 4.5 under the property MSI Engine Version

The Windows Installer 4.5 redistributables are provided as setup prerequistes.


First, what does BETA support mean? Will it work with the final MSI 4.5 (which was released before IS 2009 btw)
Second, if I cannot select MSI 4.5 as the MSI engine to use, how am I supposed to take advantage of features like chaining installs etc? Do I have to include MSI 4.5 as a setup prerequisite in that case?

Please check out this thread (http://community.installshield.com/showthread.php?t=181359).

Regards.

nitsev
06-10-2008, 08:55 AM
The Windows Installer 4.5 redistributables are provided as setup prerequistes.

Will this be the way to use MSI 4.5 features in the future as well, and not by selecting the MSI version in the release view?
What will happen if I decide to MSI 4.5 features in my install but don't add the prerequisite?

There are 5 different prereqs for MSI 4.5 in the prereqs view (pre-vista x86, pre-vista x64, pre-vista ia64, vista x86 and vista x64)
Do I have to include all these prereqs to be sure that my install will run on systems from 32-bit XP to Vista x64?

Is the Vista prereq the one that should be used when targeting Windows Server 2008?

Skane2
06-11-2008, 11:20 AM
The Windows Installer 4.5 redistributables are provided as setup prerequistes.


Please check out this thread (http://community.installshield.com/showthread.php?t=181359).

Regards.

Yesterday I installed the trial version of IS 2009 and all of the updates, but I don't appear to have any version of Windows Installer 4.5. It appears in the Application Data/Redistributables list but says it "Needs to be downloaded". When I right-click the line and select "Download Selected Item..." a MessageBox pops-up that says "The download failed. Would you like to try again?"

Am I missing something?

Christopher Painter
06-11-2008, 11:44 AM
You can tweak the PRQ files to look for the new filename and new file versions as found on the windows installer team blog. However, I suggest saving them as new filenames or otherwise you could have upgrade problems with IS releases the MSI 4.5 RTM patch.

nitsev
06-11-2008, 01:17 PM
Yesterday I installed the trial version of IS 2009 and all of the updates, but I don't appear to have any version of Windows Installer 4.5. It appears in the Application Data/Redistributables list but says it "Needs to be downloaded". When I right-click the line and select "Download Selected Item..." a MessageBox pops-up that says "The download failed. Would you like to try again?"

Am I missing something?

Sounds like you should give support a call. They should support trial installs but I am not sure. You should not have to tweak the prereqs yourself although it is a possible workaround.

Christopher Painter
06-11-2008, 01:46 PM
The reality is MSI 4.5 Beta 2 support is pointless. Who would want to ship a product that deploys beta msiexec?

Either way for an InstallShield patch or tweak the PRQ.

nitsev
06-11-2008, 03:06 PM
The reality is MSI 4.5 Beta 2 support is pointless. Who would want to ship a product that deploys beta msiexec?

Either way for an InstallShield patch or tweak the PRQ.

Yes you are right of course. IS should either issue a patch or update the existing prereqs, but meanwhile you can do it yourself.

Skane2
06-11-2008, 04:11 PM
Yes you are right of course. IS should either issue a patch or update the existing prereqs, but meanwhile you can do it yourself.

As far as Windows Installer 4.5 is concerned, there are no PRQ files in my installation to tweak. For example, the directory at "SetupPrerequisites\Windows Installer\4.5\x86\Pre-Vista" is empty.

Christopher Painter
06-11-2008, 04:16 PM
That's where the content gets downloaded. The actual PRQ is

C:\Program Files\InstallShield\2009\SetupPrerequisites\Microsoft Windows Installer 4.5*.prq

Skane2
06-11-2008, 04:41 PM
That's where the content gets downloaded. The actual PRQ is

C:\Program Files\InstallShield\2009\SetupPrerequisites\Microsoft Windows Installer 4.5*.prq

Thanks, Christopher. I see them now.

Skane

westhusing
06-19-2008, 02:37 PM
Yesterday I installed the trial version of IS 2009 and all of the updates, but I don't appear to have any version of Windows Installer 4.5. It appears in the Application Data/Redistributables list but says it "Needs to be downloaded". When I right-click the line and select "Download Selected Item..." a MessageBox pops-up that says "The download failed. Would you like to try again?"

Am I missing something?

I have this same problem. Is there something wrong on the Installshield side?

Mike Marino
06-20-2008, 10:06 PM
We just released IS2009 SP1 which corrects this issue. Go to the Tools menus and select Check for Updates to get the patch.

The English patch was released today. German and Japanese will be available early next week.