PDA

View Full Version : crash after installation of 2009



jwallenstein
06-07-2008, 08:33 AM
I have installed and register is2009 .

After start of isdev.exe comes a small progress bar
"preparing InstallShield..."
and all crashes.

Why?

On the same system I have installed full version of 2008 and 12, too.

Regards
jan

Roman1
06-09-2008, 04:40 AM
The same to me:

I have get the trial version and after Installation register this to full version.
It crashes on the same place.
"InstallShield preparing...."

I had installed the previous version: IS2008

mberterm
06-09-2008, 08:53 AM
Jan & Roman,

We have several test & support machines with seeminly similar configurations, and have not seen a crash during initialization.

That being said, I ran through a similar scenario again today:
+ XP SP2
+ IS12 Premier & IS2008 Premier
+ VS2005, SQL Server 2005
+ .Net 1.0, 1.1 & 2.0
+ IS2009 Premier, installed, activated, launched, initialized -- successfully

Jan, did you activate on-line or off-line?

Roman, did you activate IS2009 before the crash during initialization? on- or off-line?

Roman, which previous versions are on your machine?

Are there other 'development' applications on the machine?
+ Visual Studio, which version(s)?
+ VS plug-ins
+ .Net version(s)
+ were the previous IS versions Professional or Premier?

What is your default browser and what is its version?

If another machine is available, it would be useful to see if the crash is machine specific.
1) uninstall IS2009 from the current machine and
2) install, activate & launch on a different machine

Thanks,
-Mike

Roman1
06-09-2008, 09:38 AM
Roman, did you activate IS2009 before the crash during initialization?
-- After installation (with ser.number) I let IS2009 start bei last window of setup. Than came the progressbar "initialisation..." and is2009 crashes.
After this I have activated it online. Activation was ok.
By the next starts is2009 crashes on the same place

Roman, which previous versions are on your machine?
-- is2008

Are there other 'development' applications on the machine?
+ Visual Studio, which version(s)?
-- none
+ VS plug-ins
-- none
+ .Net version(s)
-- only 3.5 Installation
+ were the previous IS versions Professional or Premier?
-- Premier, trial

What is your default browser and what is its version?
-- IE6

If another machine is available, it would be useful to see if the crash is machine specific.

-- I have install is2009 on VMWare 5 as another PC, now
-- This VM has also is2008 installed.
-- It crashes on this same place

Roman

mberterm
06-09-2008, 03:39 PM
Thanks for the information Roman. While it does not seem out of the ordinary, I am interested to see what Jan has to say ... and to see what similarities there are.

Which OS (and service pack level) is installed to the machine? What is the language of the OS & of IS?

When launching InstallShield2009, the EXE can log its progress. Change the value from 0 to 1 in order to enable the logging.

Key: HKEY_CURRENT_USER\Software\InstallShield\15.0\Professional
Data: DoVerboseLogging
Default Value: 0

Then look for the InstallShield.log file in the <System> directory, by default found in this path <C:\Program Files\InstallShield\2009\System>.

After the log is generated, please contact support to review its contents.

jwallenstein
06-10-2008, 01:43 PM
Hello,
we will not upgrade to is2009.
It gives us at this time no benefit.

This isue is closed

Jan

mberterm
06-11-2008, 10:04 AM
Working with Roman through PSS, the crash is caused by an issue in the template validation routine during the first-time start up.

The problem with in the template is still being researched.

However, as a temporary work around, the validation can be disabled. Please contact Support for further information.

mberterm
06-12-2008, 01:25 PM
A fix has been found.

The fix can be gotten through Support as a one-off type of hotfix and is to be included in the next future formal release.