PDA

View Full Version : IS2008Express/Java 1.6



Bodger
05-09-2008, 12:11 PM
I am building an installation. I want the target machine to have Java 1.6 installed in it before my installation begins (nothing will work, nor will the installation complete if Java 1.6 is not available, I call some custom actions that depend on Java 1.6).

From the "Installation Designer View"

- I see a "Requirements" section and it lists things like IE6/7, Adobe Reader etc. But not Java 1.6 or any Java.

- There is another section called "Redistributables" which might fill the bill, but it only has a section for Java 1.5 which is inadequate.

1) Is there a way to make sure the machine has Java 1.6?
2) Is there a Java 1.6 redistributable?
3) In the redistributable section, I really do not want to include that redistributable in my installer, is it possible for that to do an install via the internet directly if Java 1.6 is not on the system?
4) Assuming the redistributable exists does this install Java 1.6 only if Java 1.6 is not on the system?

Thanx

Julian