View Full Version : Setup Launcher has stopped working

03-24-2008, 03:39 PM
I created an install for Windows Vista and Longhorn using InstallShield Express 2008 (version 14 - there are no product updates pending). When I run the resulting setup.exe file on a clean install of Windows Vista (Business Edition), I immediately get the error that "Setup Launcher has stopped working".

This error is apparently a Windows catch-all error handler for programs that stop working. I have searched Google and Macrovision websites for possible clues as to what is causing this problem and cannot find anything to help me resolve this. I have even created a very simple install setup.exe that has no dependencies, no merge modules, only one file to deposit on the user's hard-drive (a small JPEG image), and is restricted to Windows Vista. The setup.exe is very small (840kb) and it results in the same error message when run.

In order to verify if the Setup Launcher is the problem or the install package is the problem, I have also made a setup that creates just an MSI file, and no setup.exe is built. When I run the MSI file on the Vista machine the installation works perfectly.

Does anyone have any ideas for how to resolve this issue? I'd really like to distribute my software with a setup executable and not just an MSI file.

Thanks in advance for your help!

03-27-2008, 10:23 PM
I discovered that the problem was due to how I was transferring the setup EXE file to my Vista test machine. I was copying the setup.exe file onto a USB 2.0 flash drive and then moving it to the Vista PC and copying from the flash drive to the desktop. Somehow the file was being corrupted by the transfer method or the USB device. When I tried FTP'ing the file to our web server and downloading it (like a user will), I found that the installation worked just fine.

Strange problem... but a reminder that any step in the process can be a suspect in solving difficult software problems.