PDA

View Full Version : Unable to install files to 'Windows\System32' folder, in a 64 bit environment



JoelRaj
03-17-2008, 05:38 PM
Hi,

I am creating a generic installation package using IS 2008 express. I specified the INSTALLDIR as [WindowsFolder]System32, as per my requirement. When I run the exe in a 64 bit OS, the files always get copied onto the 'Windows\sysWOW64' folder. Is there any way to force the installer to install onto the Windows\System32 folder ? almost I tried all options, still no hope.

Note:

1. The installation package was created in a 32 bit OS, and it is working perfectly in a 32 bit OS

2. The target m/c is a Windows 2003 server

3. Options tried so far in the INSTALLDIR field, a) [SystemFolder] b) [WindowsFolder]System32, c) [System64Folder]

Please help.

Thanks,

Raj

bryanwolf
03-18-2008, 09:19 AM
The folder it's installing to is the 32-bit System32 folder. Since 32-bit applications are redirected to specific portions of the system for compatibility purposes, you will in all liklihood want your fiile installed there.

JoelRaj
03-18-2008, 05:10 PM
Got it. Thanks Bryan

Johan007
09-10-2008, 12:42 PM
But if you really want the file to be installed under "System32" and not "SysWow64", because the file is a 64-bit file.

Is there any way of achieving that using InstallShield Express?

Is InstallShield Express ready for 64-bit installations or not? Does anyone know?

DebbieL
09-10-2008, 03:23 PM
Please see the follow-up here:
http://community.acresso.com/showthread.php?t=183441