PDA

View Full Version : Error 1935 during installation – IsSaBld, MsBuild issue



s_tenlly
03-05-2008, 03:24 AM
Hi All,

My setup installs a .NET assembly into GAC. My project is an InstallScript-MSI and I am using InstallShield 2008 Professional and InstallShield Standalone Build 2008.

Well, if I am using IsCmdBld or InstallShield IDE to compile my installation – the installation works without errors.
But if I am using MsBuild or IsSaBld to compile, I am receiving Error 1935, HRESULT 0x80131047 during the installation.

I found the source of the error but still not a solution.

Using MsBuild or IsSaBld:
There are two similar entries in the MsiAssemblyName table for "ProcessorArchitecture".
The difference is only the fist letter case - 'P' and 'p'. I am receiving error 1935. If I delete the ‘processorArchitecture’ entry with Orca, the installation works fine.

Name Value
ProcessorArchitecture MSIL
processorArchitecture MSIL


Using InstallShield IDE or IsCmdBld:
There is only one ProcessorArchitecture entry in MsiAssemblyName table and the installation works.

Name Value
ProcessorArchitecture MSIL

Is there an error in IsSaBld /IS support for MSBuild/?
Or maybe I must add some additional options in my .isproj file.

Thanks in advance!

Regards,
stenlly

s_tenlly
03-07-2008, 03:01 AM
I must make more exact.
I am checking the MsiAssemblyName table in MSI file using Orca and not in .ISM file.

MichaelU
03-07-2008, 08:43 AM
Are you seeing this behavior with all GAC-destined assemblies, or just certain ones? You mention a difference in behavior between a standalone build environment and the IDE environment; did you try MSBuild on a machine with the IDE environment, or only on the SAB environment?

s_tenlly
03-10-2008, 02:32 AM
Yes, this error occurs with all GAC-destined assemblies. Or it is better to say all in this project. I tried MSBuild on my machine (with IDE environment), the result was the same.
Well, I will create a sample project and will try this issue again.

I’ll post the results later.

s_tenlly
03-11-2008, 02:48 AM
I found the error. The error was on my side.

The project was first developed with InstallShield 11.5. There was an error with .NET 2.0 Assemblies and GAC in IS 11.5 – ProcessorArchitecture is missing in MsiAssemblyName table. The build script was modifying MSI file to fix this error.

MichaelU
03-11-2008, 10:55 AM
Good find, and glad to hear it's working now. It's always fun when fixing a clear bug causes a problem down the road. :D