PDA

View Full Version : Error 1925 during installation in Windows Vista



LKM_N4EN
03-04-2008, 09:50 PM
Hi,

I am new to IS and now creating a basic msi installer for standard user in Windows Vista. In the project, "Require Administrative Privileges" has been set to "No" and I have change the setup.exe "Required Execution level" to "Invoker" which means all user can run it.

But when I installed in Windows Vista, the error 1925 occured saying that "You do not have sufficient privileges to complete this installation for all users of the machine. Log on as an administrator and then retry this installation."

Please anyone can help me on this? any other settings i have not configured?

LKM_N4EN
03-05-2008, 02:53 AM
I tried using the "Certified for Windows(R) Vista Validation Suite (plus InstallShield ICEs)" to check the error.

It returned the error code "ISICE20" with description "Row <ComponentName> of Table Component: installing, modifying, or deleting a file in directory INSTALLDIR requires elevated privileges, but this package does not request elevated privileges"

So where should I put the files?

MichaelU
03-05-2008, 10:59 AM
The setting "Require Administrative Privileges" under the General Information > Summary Information Stream should only be set to no if you are creating a per-user installation; you probably want this to be Yes. This option controls whether Windows Installer will elevate the execute sequence, not whether launching the setup will elevate immediately.

If intentionally creating a per-user install, generally one would target INSTALLDIR to a per-user folder, and make sure to remove the ALLUSERS property.