PDA

View Full Version : Vista Installation error



bythebook
02-11-2008, 06:00 PM
I'm getting the following error on a vista machine when I run my installer: "Administrator has set policies to prevent this installation". The user is logged in as Administrator and isn't aware of any special settings. I have the setup.exe execution level defined as Invoker. We've run this installer on other vista machines without any problems.

Can anyone direct me to a solution??
Thanks

victorcamp
02-14-2008, 04:06 PM
I don't know if this will help you or not, but I've recently been tracking down that error for other situations on my Vista machine.

If your machine was an update from XP, or if you brought over directories from another computer, the "Owner" of some directories might be "TustedInstaller" instead of "Administrators", thus preventing the Administrator from making changes.

1. Log in as administrator.
2. Open an Explorer/Computer window and navigate to the folder/directory or file that might be causing the problem (e.g., "Program Files").
3. Highlight and bring up the folder's "Properties" (right-click).
4. Move to "Security" tab.
5. Choose "Advanced."
6. Move to "Owner" tab.
7. You may see the owner listed as "TrustedInstaller."
8. Choose "Edit."
9. Highlight "Administrators" (note plural).
10. Put a check in the box for "Replace owner on subcontainers and objects."
11. Click "Apply." (It may then have to go through quite a long list.)
12. "OK" all the way out.
13. Try installation again.

(With thanks to other forums' members and Microsoft Knowledge Base.)