PDA

View Full Version : (lmgrd) Can't open /usr/tmp/.flexlm/lmgrdl.4081, errno: 24



flexlm668
01-24-2008, 05:06 PM
We are a tool vendor and one of our users is getting this error.
The user is using several macrovision license enabled products including ours.


(lmgrd) Can't open /usr/tmp/.flexlm/lmgrdl.4081, errno: 24

At this time, it stops checking out licenses, and will not
respond to query's.

What's weird, is that the file /usr/tmp/.flexlm/lmgrd.4081
does exist! And the process is 4081. Everything else seems
to be fine. For some reason, it wants the file base name to
be "lmgrdl" instead of "lmgrd".

At this point in time, we have to kill and restart the
License Server. It will work for a few days, to a week or
two, then do this again. We are running

"syntest v10.8.0.1 build 19446"
"lmgrd v10.8.0.1 build 19446"

Is this a know problem?

Is there a fix and/or work-a-round?


Thank you for any help and suggestions.

delgado
01-29-2008, 10:31 AM
Hi,

I was having the same problem. This was Macrovision's suggestion:

This problem is related to the configuration of the OS.

The failure to open the file lmgrdl.12049 (which is the lock file) and the queuing of users for the feature was caused because there were too many files open (the limit of which is been restricted by the file descriptor limit.

A file descriptor limit is a handle created by a process when a file is opened. There is a limit to the amount of file descriptor per process. The default Solaris file descriptor limit is 64 )

Starting the license server with the following parameter has the effect of increasing this limit and resolving the problem:

#!/bin/sh ulimit -n 1024 ulimit -H -n 1024 lmgrd [...]


I hope this helps

efbrandt
03-22-2010, 08:57 AM
I suffered with this for over a year with all kind of bandaids. Since i set the tcp_time_wait_interval to 2400 a week ago I have had no problems.

I',m running on Solaris 10

ndd -set /dev/tcp tcp_time_wait_interval 2400