PDA

View Full Version : ActiveX component can't create object



rogdawg
12-04-2007, 01:38 PM
I have created a project that builds correctly, with no errors. However, when I run the setup.exe and try to launch the application, I get:

Run-time error '429':
ActiveX component can't create object

Most posts that I have found regarding this error say to check the registration type of the dlls in question, to ensure that they use "Self-registration". I have tried this and it seems to have no effect at all.

I placed some debug code in the initial Form.Load event of my application to see if error was caused when the app. tried to load a control. Then I rebuilt the setup program, and re-installed it. But, the error occurs before the form.load event occurs, so my code never runs.

I am at a loss.

This is a VB6 application that we are maintaining until an updated version can be built. We have been able to produce good setup programs in the past, and I am actually using some very old .ism files, converted to .isi. I have also used a very old version of InstallShield (3.03) to produce a setup.exe file, and I get the same results.

Any suggestions for debugging the problem or, better yet, SOLVING this problem, would be greatly appreciated. I have burned 3 days on this problem, and I REALLY need to get a good setup program that actually works.

Thanks, in advance for any help you can provide.

rogdawg
12-05-2007, 05:00 PM
I found the solution. It was a missing reference to a dll.

D'oh!