PDA

View Full Version : Express 2008 does not recognize .NET Express



wayneh
11-09-2007, 10:59 AM
I have Visual Studio 2005 Express (C#) installed and when I try to run the "C# .NET Wizard" from Express 2008, it tells me that "Visual Studio .NET must be installed on your system to continue this wizard"

It IS installed - or is ISE 2008 just not capable of working with VS Express?

MichaelU
11-09-2007, 03:31 PM
The latter - the Visual Studio Express editions do not load third party extensions of InstallShield's type.

wayneh
11-09-2007, 04:59 PM
I'm sorry - huh?

Are you saying that I can't use ISE 2008 with VSExpress 2008?

Why not?

I'm trying to run ISE 2008 - so I can't use it to build an installer for my C# projects created with VS2005?
How am I supposed to distribute my apps?

MichaelU
11-12-2007, 01:50 PM
I'm saying the Visual Studio Express editions do not allow us (or anyone else) to integrate with them. So if you're using the Express edition of Microsoft's product, you will have to work separately. You can still use our .NET dependency scanning support, etc., but you're best off starting with a fresh Express project and adding the files you need to install in the Application Files or Application Data > Files view

wayneh
11-12-2007, 03:54 PM
I guess I'll have to upgrade Visual Studio to the Standard Edition - you integrate with that one, correct?

Thanks.