PDA

View Full Version : The vendor daemon cannot be stopped using lmdown



delgado
08-14-2007, 09:45 AM
Hi,

has someone experienced this case?

We have a Solaris 8 server triad, the version of lmtools and our vendor daemon is 10.8.0.1.

We are using an opt file, this opt file changes every day (new users are added other are removed) so it's required to restart the service in order to these changes take effect. We stop and start the server using a script with a delay of 5 min between start and stop, we have also set the TCP/IP settings tcp_time_wait_interval to 24000 as recommended. We also use the port=xxxx in the server line of the license file and start the license server with the - reuseaddr parameter.

Sometimes lmgrd stops but the vendor daemon does not. The problem comes when the server is started again: It's detected that the port is already in use and the
server won't start. :confused:

Has someone experienced this problem?

Any ideas/suggestions will be deeply appreciated

Thanks !

RobertDickau
08-14-2007, 01:21 PM
What is the full lmdown command you're using? Is there any information in the debug log about the attempted shutdown?

delgado
08-16-2007, 08:36 AM
The command used to stop the server is the following:

/usr/license/ascet/bin/lmutil lmdown -f -c /usr/license/ascet/license/license.dat

This an extract of the debug log, it looks like the lmgrd is being finished before the vendor daemon. Is that possible?

14:52:38 (ETAS) REMOVING witulewe@SI60477:SI60477 from ASCET-SE by administrator request.
14:52:38 (ETAS) IN: "ASCET-SE" witulewe@SI-Z1682 (USER_REMOVED)
17:06:15 (lmgrd) TIMESTAMP 8/13/2007
23:06:15 (lmgrd) TIMESTAMP 8/13/2007
5:01:01 (lmgrd) Forced shutdown requested
5:01:02 (lmgrd) SHUTDOWN request from root at node rb-flex4

5:01:02 (lmgrd) lmgrd will now shut down all the vendor daemons

5:01:02 (lmgrd) Shutting down ETAS
5:01:07 (lmgrd) Can't connect to the license server system. Shutdown ETAS failed.
5:01:07 (lmgrd) No socket connection to license server manager. (-7,10015)
5:07:10 (lmgrd) By default on Solaris, upon stopping a license server,
5:07:10 (lmgrd) 1 to 5 minutes are required for the port to free up so it
5:07:10 (lmgrd) will restart, which can result in checkout failures.
5:07:10 (lmgrd) The command above resets this default to 2.4 seconds
5:07:10 (lmgrd)
5:07:10 (lmgrd) -----------------------------------------------
5:07:10 (lmgrd)
5:07:10 (lmgrd)
5:07:10 (lmgrd) The TCP port number in the license, 28005, is already in use.
5:07:10 (lmgrd) Possible causes:
5:07:10 (lmgrd) 1) The license server manager (lmgrd) is already running for this license.
5:07:10 (lmgrd) 2) The OS has not "cleared" this port since lmgrd died.
5:07:10 (lmgrd) 3) Another process is using this port number (unlikely).
5:07:10 (lmgrd) Solutions:
5:07:10 (lmgrd) 1) Make sure lmgrd and all vendor daemons for this
5:07:10 (lmgrd) license are not running.
5:07:10 (lmgrd) 2) You may have to wait for the OS to clear this port.
5:07:10 (lmgrd) Retrying for about 5 more minutes
5:07:28 (lmgrd) Still trying...
5:07:46 (lmgrd) Still trying...
5:08:04 (lmgrd) Still trying...
5:08:22 (lmgrd) Still trying...
5:08:40 (lmgrd) Still trying...
5:08:58 (lmgrd) Still trying...
5:09:16 (lmgrd) Still trying...
5:09:34 (lmgrd) Still trying...
5:09:52 (lmgrd) Still trying...
5:10:10 (lmgrd) Still trying...
5:10:28 (lmgrd) Still trying...
5:10:43 (lmgrd) Failed to open the TCP port number in the license.

delgado
08-16-2007, 09:37 AM
we also realized that the vendor daemon uses 100% CPU !

Thanks

RobertDickau
08-16-2007, 11:12 AM
As a test, does it make any difference if you use lmreread instead of lmdown?

delgado
08-17-2007, 04:46 AM
In this case reread doesn't work. These servers are used worldwide so there are always borrowed licenses. And (as far as I know) reread doesn't work if there are borrowed licenses, isn't it?

In addition, the restart of the license services is executed because the options file changes almost every day (we talk about a big company). This is required so the license server takes the last changes in the options file.

If the reread were capable of reread the license file although there were still borrowed licenses and were also able to take the changes in the opt file the problem were solved :)

RobertDickau
08-21-2007, 10:16 AM
Has lmreread failed on your system? A quick and simple test seems to work at this end (though I haven't tried it with a triad).

As a general tip, you might see if newer versions of lmutil and lmgrd will help; please see, for example, the lmgrd and lmutil customer download page (http://www.globes.com/support/fnp_utilities_download.htm).

delgado
10-26-2007, 04:48 AM
Updated to v10.8.5.0. But still have a problem: If I try to stop the license server while there are borrowed licenses using the -force parameter I receive an error message saying: Unknown argument: -force.

lmdown -c license.dat -force

Which could be the problem here?

RobertDickau
10-26-2007, 07:21 AM
That's odd: does "-force" appear if you run lmdown -?? Does it work if you switch order:

lmdown -force -c filename.lic

...?