PDA

View Full Version : .NET 3.0 download - not as Prerequisite



rslangham
07-11-2007, 12:22 PM
Ok, I had InstallShield 11.5 for our .NET 2.0 applications and we used the Release/.NET feature where it would automatically download and install .NET 2.0 if not installed on the user's computer. So, went and spent the big bucks for the InstallShield 2008 to get .NET 3.0 support (as advertised new feature).

Come to find out it is now a prerequisite now and not implemented as .NET 1.0/2.0 are implemented. Meaning, it doesn't provide the option to download and install if the user does not have it (rather than having to include .NET binaries with the install image). It appears that we now have to include the .NET 3.0 in our install image (a huge 50 Megs) regardless if the user already has it already installed or not.

Is this really the case!!

If so, is there any easy way that we can detect if .NET 3.0 is installed and prevent the install of our app and just inform the user they must install first, ideally with a URL to download.

SherylSikora
07-11-2007, 02:01 PM
You can set the prerequisite to be downloaded. Just select "Download from the Web" in the Releases view - Setup.exe tab - "Setup Prerequisites Location" property.

rslangham
07-11-2007, 03:07 PM
Thanks for the quick reply. I see now that there is better support for this than originally thought. Not so :mad: now :) Just the change from the previous InstallShield version threw me for a loop.

So, after looking at this more, I see that actually I have possible more fine-tuned options within the Redistributables view rather than having to set it globally for the entire install via the Releases view as you suggest.

In the Redistributables view, if I right click on the .NET Framework 3.0 and select Properties here I can select Download just for this Prerequisite and leave the others as default. And also from this menu I can go into the "Edit Prerequisite" and modify other entries. It appears from here that the .NET 3.0 has all the values all filled in along with a URL to saturn.installshield.com/... for downloading.

Are all these values for the .NET 3.0 populated by InstallShield correct and supported, so I just simply have to select the option to be download from the web and all else should be fine?

Thanks,
Ron

SherylSikora
07-11-2007, 03:10 PM
Yes, those are the locations we support. I even tested it myself just now to make sure :)