PDA

View Full Version : Problem (error 6401) when converting 11.5 project to 2008



wxinlll
07-02-2007, 12:58 AM
hi, I am just new to the InstallShield and no idea how to solve these problems when trying to convert from 11.5 to 2008.

Our project is a multilingual one, including english (United States), spanish (Modern Sort) and Portuguese (Brazil). I have two issues here when performing the conversion.

1) Spanish (Modern sort) is not supported and the New Language wizard seems not functioning or it works different from the 11.5. Does anyone successfully add a new language into your project which are not supported by default?

2) I attempted the build without Spanish (Modern Sort). Everything works fine until the step after building the Data1.cab. The log is as follows:

Resolving strings...
Language English (United States) built
Building CAB files...
Data1.cab built
Files built
ISDEV : fatal error -6041: Internal build error
PROJECT_ASSISTANT\SINGLE_EXE_IMAGE - 1 error(s), 17 warning(s)
It seems some error occuring before or while building the media table and setup.exe.

our project is a basic MSI one without any custom install script. Could anybody suggest? Thankssssss :)

SherylSikora
07-03-2007, 04:45 PM
Re #1: Are you using the Premier edition of IS 2008? If yes, when you say the wizard is not functioning what is the behavior that you are seeing?

Re #2: Please build your setup using the command line builder (IsCmdBld.exe) and pass in the verbose flag (/v). This might give us some additional information in the build log. Post the log here once that is done. In case you don't know how to use the command line builder, here is a link to our HelpNet documentation:
http://helpnet.macrovision.com/Robo/BIN/Robo.dll?mgr=agm&tpc=%2Frobo%2Fprojects%2Finstallshield14helplib%2FIHelpCmdLineBld.htm&wnd=InstallShieldLivingHelp%7CMain&agt=wsm&ctxid=search%2Fgsearch.asp

wxinlll
07-03-2007, 10:40 PM
Thanks for your reply.:)

#1 -- steps
1) Launch the New Language Wizard from "Tools"
2) Choose the Language I want to add, e.g. Spanish (Modern Sort) from the list, and then Click "Next" button.
6115
Within this dialog, there is no response when clicking at "Next" no matter which language I choose. however, it seems not hanging because the rest 3 buttons are all working.

#2 -- I will upload the logs soon. Thank you in advance

wxinlll
07-04-2007, 03:59 AM
Attached is the build log. Sorry that I have to remove the product relevant information... :p

6116

SherylSikora
07-05-2007, 12:44 PM
It looks like Spanish is still being built with your project. Have you verified that all references to this language have been removed?

As for the wizard - I am still looking into that. As far as I know the wizard should work fine. Do you have IS 11.5 and IS 2008 installed on the same machine together (which should not be the cause, I just want to gather more information)? Have you tried re-installing IS2008 by chance?

wxinlll
07-06-2007, 01:53 AM
Thanks Sheryl :p

The InstallShield 2008 and 11.5 are in different machines from the beginning. I reinstalled the 2008 twice already, but still looks the same.

For the build error one, I will try out what you have said. Will update the result soon.

Thanks again and have a nice day

wxinlll
07-06-2007, 04:34 AM
Sheryl,

For the New Language Wizard problem, we just had a workaround. Create a new project using InstallShield 2008, and try to add new language to this project. This is successfully completed. After these all, I am able to add any language in the New Language Wizard to our project. It is really strange, isn't it?

For the 6041 build error, can advice how I can fully remove the reference to Spanish?

Thanks a lot and have a nice weekend :)

SherylSikora
07-06-2007, 12:13 PM
It appears then that the issue with the Language Wizard is somehow related to upgraded projects. We'll take a look and see what we can find. I'm happy that you were able to fix it though.

To start trying to fix your build error, I would remove all languages except English in your project (General Information|Project Properties view). Then in the Direct Editor verify that the ISLanguage table only lists 1033 as included and the ISString table only has entries for the 1033 language. Also verify that your release (in the Releases view) does not have any references to any other languages than English (1033). Going through the Release Wizard would probably be the best way to do that.

And just for the sake of being thorough, try running validation (in the Build|Validate menu) on the project and see if it gives you any errors or warnings.

wxinlll
07-18-2007, 12:55 AM
Hi, thanks for your information. Actually I have figured out the build failure is due to the Portuguese language. When I remove it from the Setup Languages List, the build is smooth. Wondering whether it is due to special characters inside the string table.

Actually I tried to import the string table from the original 11.5 version, and i did not change anything. Dunno why it just failed... can suggest? Thanks~~

wxinlll
07-19-2007, 12:29 AM
More information about the error:

If I include the portuguese language but import english to the string table, the build is still successful. Only when I import back our portugues string table, the failure occur.

SherylSikora
07-19-2007, 03:07 PM
If you build an uncompressed image, does the error still occur? Does the error occur in a new project with just the Portuguese string table included?

Tim Mayert
11-01-2007, 11:57 AM
Actually I just ran into the 6041 internal error myself and I have 30 languages in my install.

I checked everything in the languages and string tables and what I found was that if the time stamps for any of the language strings do not exist then you'll run into problems. I check mine and it looked like the Japanese strings did not get timestamped when loaded. I simply filled in all the missing time stamps and then rebuilt the project. Now it builds fine.

So this is one thing that can be checked before removing and re-adding a language because if you already added your own translated text for a language you would not want to remove and re-add the language as you would have to re-add all the strings that you created as well.

Hope this helps.