PDA

View Full Version : Help!! Vista and InstallShield and more...



U42093
06-25-2007, 03:05 PM
A laundry list of questions.


1. Using IS12 Express, my ActiveX (COM) components deployed to client computers are not registering properly on Windows Vista client machines. I have tried running the installer "As Administrator" and "normally", (which I ddin't think I'd have to do since the InstallShield setting for "Require Administrator Privileges" is set to "Yes".) Nevertheless, in both instances, the ActiveX controls are not properly registered. Trying to manually register them with REGSVR32 is also unsuccessful. The only successful resultion is to manual *UN*register the components from an Administator command prompt with RegSvr32 /U, then manually re-register each affected DLL and OCX file. The Macrovision forum includes a user-suggestion to write a DOS batch file that is executed at the end of the install to force the un-register and re-register, but this just seems like a kludge, and I'd like to know if there is an official solution that runs inside the InstallShield framework.

2. If an InstallShield install is run without forcing "Run As Administrator", the installer is unable to extract the install to C: \ Windows \ Downloaded Installations. The Macrovision website suggests changing the location of the extracted files from [WindowsFolder] to [LocalAppDataFolder], but gives no clue where to find this setting in IS12 Express. I've been digging through the menus for hours, and I can't find it. I'm sure I'm missing it, but it's eluding me.

3. I am pretty sure that I don't have SP2, although I keep reading that there is an SP2 for IS 12 Express. Is there a service pack or not? When I run "Check For Updates" from inside IS 12, it says there are no updates. How can I determine if I have this elusive "Service Pack 2" ???

sbiswas
07-17-2007, 03:09 PM
Well... I faced the same problems as you and finally I figured out the following to solve the problem....

1. ActiveX Registration problem....
In 'Installation Designer' view, go to the tree node 'Build Your Release' and select the appropriate build type (e.g. SingleImage). On the right side you get list of options. One of the options is 'Required Execution Level'. Select 'Administrator' as the required execution level. This solves the ActiveX deployment problem.

2. In the same options (mentioned above) you also have one of the option as 'Location For Copying Media'. Thats where you can change [WindowsFolder] to [LocalAppDataFolder]. However, if you do what I have suggested in Sl.No.1 then you will not need to do this at all.

I cant say if the above is the best way of doing things, but this works for me :)

Cheers!

Wakerunner
08-10-2007, 11:11 PM
You suggestion to set 'Required Execution Level' to 'Administrator' did not work. I am able to install on my test Vista computer with Vista Business as long as Vista UAC is on (Althought even then I do get an error message on the first run after install but the next run I don't get the error). However when UAC is off I get the registration errors even with the change to required execution level.

Anybody know how to fix this, I was assuming that this was a bug in Vista and it would be fixed soon but Vista has been out for a while now and it is still doing the same thing.

bryanwolf
08-13-2007, 08:30 AM
Try right-clicking on the setup and selecting "Run As Administrator".

Also note that disabling UAC by default only disables the UAC prompt and auto-fails on elevation requests.

enounce
08-17-2007, 11:51 AM
A related problem is getting a program that is installed to run as administrator under Vista. I didn't notice any flags in IS12Express to set this on the shortcut to the program. Does anyone know a way to make a program run as administrator.

bryanwolf
08-28-2007, 08:21 AM
Windows Installer does not support that functionality, enounce. You will have to write a manifest file for your main executable that will trigger Vista to elevate your application.