PDA

View Full Version : Two futures - Error:27500



mgolka
06-25-2007, 06:14 AM
Hi,

I have two futures Client and Server. Client installation has nothing to do with IIS server, hower when I start it on any PC without IIS server installed I get an error 27500.

I think this was working in 11.5 version but I can't open the project in 11.5 any more. Is it any chance to do solve the problem or do a downgrade of a project file?

Thanks

mgolka
06-25-2007, 09:06 AM
"Error 27500. This setup requires Internet information Server 4.0 or higher for configuring IIS virtual root. Please make sure that you have Internet information Server 4.0 or higher"

mgolka
06-25-2007, 10:20 AM
I have a WebSite (Default Web Site) and a Virtual Directory.
Virtual Directory is visible only for Server installation.

If I remove the Web Site (just for test) then it works.

davidh
06-25-2007, 10:55 AM
That is the expected behavior. See the following post for more info, although you have more limited options with the Express version of the product:
http://community.installshield.com/showthread.php?t=170830&highlight=iis

mgolka
06-25-2007, 11:31 AM
Could you please give me a solution for the InstallShield Express ver 12?

Thanks

davidh
06-25-2007, 12:59 PM
This will be in the next version of Express. However, for now there is not much you can do from within Express. You might want to use two different setups perhaps.

2 things that might help:
1. We check the registry key "SYSTEM\CurrentControlSet\Services\W3SVC\Parameters" to see what version of Express is installed. Then we set the IIS_VERSION property based on the MajorVersion value. Maybe you can reset the value somehow? Again, your options are limited with Express.
2. You can use a tool to modify the msi that is built, such as Orca. However, that is outside of our product so it is not supported. Using that tool, you can modify the conditions of the custom actions in your install using the above link as an aid.

mgolka
06-26-2007, 07:32 AM
It seems that the best solution for me will be to downgrade the project into 11.5. Is there any chance to open the project saved in v.12 in IS 11.5?

Thanks

davidh
06-26-2007, 10:14 AM
Sorry, the Express version of the product does not allow you to 'save as' an older version. Pro\Premier versions do. However, in this case I don't think the behavior is different with 11.5. Maybe you can test it with 11.5 to verify that.

mgolka
06-26-2007, 10:48 AM
It definitly is different in 11.5 this is why I am so upsed. I lost much time because I upgraded the project to v.12. I took the project from vss (last 11.5 vbersion) and then added manually the difference.
In 11.5 it works!

davidh
06-26-2007, 10:52 AM
I apologize for the inconvenience, but my understanding is that behavior did not change from 11.5 to 12 (I'm talking about Express versions here). Can you verify that with a new project built with 11.5? I do not have 11.5 installed at the moment, but it should take a couple of minutes of you have 11.5 installed.

mgolka
06-27-2007, 03:35 AM
I can do it but probably not earlier then tomorrow. I have my setup in 11.5 now and it works correct.
Kind Regards

davidh
06-27-2007, 11:18 AM
When you converted your project to 12 from 11.5, a backup should have been created. You can rename that backup file to open it in 11.5.

Also, I think you can modify the 12 file to put conditions on the custom actions as mentioned before. But again, that will have to be done with a free tool such as orca since you are using the Express version.