PDA

View Full Version : Problem with New Microsoft .NET Framework Object



ced_oce
06-21-2007, 05:16 AM
Hello,

The object "New Microsoft .NET Framework Object" makes part of my InstallScript project, but it seems that it does not detect that the Framework is already installed, so, each time I installed the package, the object installs the Framework!

At the end of the installation, the .Net Framework is correctly installed, but at the next installation the object will again display the message "Installing Microsoft .Net Framework 2.0" and will again install the Framework...

I checked in the options but I did not find any way to avoid installing the Framework if it is already installed...

Thanks,
Cédric.

CRCInfoSys
06-21-2007, 04:26 PM
You'd probably be better off not using the object. I put the installer into my support files. Then I check to see if .net 2.0 is installed. If it is not, I run the installer.

DevinEllingson
06-21-2007, 06:25 PM
ced_oce,

On first UI mode the object should automatically detect that the .net framework is installed and skip the install in this case (unless you have changed the "AlwaysInstall" or "AlwaysRepair" property.) (Note however that the .net redist will still be installed it just won't be launched)

In repair mode the object will always attempt to install the framework (since repair is supposed to reinstall items that are already installed), unless you change the "AlwaysRepair" property.

Both the "AlwaysInstall" and "AlwaysRepair" properties should be listed on the help page for the object.

Also, did you add this object to your project in this version or was the object upgraded by the upgrade of the project from a previous version?

Devin Ellingson
Software Developer
InstallShield, A Macrovision Company

CodespringsMike
07-23-2007, 09:18 AM
Hello,

I am seeing this same problem. I am using the new .NET InstallShield Object in an InstallScript project that was upgraded from version 12 of InstallShield.

I do not see where the .NET framework install is being detected in the OnFirstUI event in code, however like I said, my project was upgraded from a previous version of InstallShield.

What can I do to get this to work?

Also - if I could simply detect whether or not the .NET framework is installed via code, then I could control this myself. Could you tell me how to detect if the .NET framework is already installed an what version it is?

Thanks,

Mike

CRCInfoSys
07-23-2007, 09:30 AM
if (! Is( DOTNETFRAMEWORKINSTALLED, REGDB_KEYPATH_DOTNET_20 )) then

This will check if .Net 2.0 framework is installed. If you check out the Is keyword in the Installshield Help Library, you can see how to check for other versions of the framework.

I hope this helps.

CodespringsMike
07-23-2007, 10:38 AM
Very good - Thank You. I have not used the Is method yet.

Thanks Again,

Mike