PDA

View Full Version : InstallShield 2008 Cleanup



JohnMike
06-20-2007, 09:24 AM
I'm testing my first InstallShield 2008 project. It's a very simple Basic MSI project just to install .NET 2.0 and a Crystal Reports Merge Module.

I'm testing this on a Virtual PC (in case that matters). The installation works fine, but when the Setup program has completed (the final dialog window with the Finish button has been clicked), it seems to leave a "InstallShieldMSIDelete10" process running. This seems to stay running for a 'very' long time (so far I haven't seen it complete). This process does not show up on the Task Manager but if I try to close the Virtual PC, it says this is still running.

The problem I'm having with this is that I had plan on launching the setup program from another VB.Net application by shelling out to run it. I have the Shell prompt waiting for the setup program to complete before the VB.Net application continues but it never continues since it thinks the Setup program is still running.

Does anyone know if I may have done something wrong in my setup program to cause this or is there any way around this. I'm not sure if it's just a problem in my Virtual PC (since it runs very slow anyway) or what.

I would appreciate any information anyone can provide me.

gridman
06-21-2007, 12:15 PM
I use Virtual PC and Virtual Server all the time and I have virtual machines set up with all the Windows operating systems.

I just tried to install my current Basic MSI installation on a Win Vista virtual machine, the install finished and I checked the task manager and there was no InstallShield process still running.

What Windows OS does your virtual machine run (the one you have having a problem with)?

JohnMike
06-21-2007, 12:48 PM
The OS that I'm running the Virtual PC on is Win2000 with most of the recent updates. I did just upgrade to VPC 2007 just to see if that ran any better but same result.

I am running this VPC with the Undo disk Enabled with 512 MB of memory (my comptuer has a total of 2GB of memory, Pentium 4 CPU 2.66GHz, XP Pro SP2)

Just today I managed to test my installation on an actual computer and it does seem to be working fine and terminating correctly (this was confirmed since my program that launches the InstallShield application later tries to delete the file so it doesn't leave a large file on our client computers. In the VPC it was never able to delete the file since it's reported as being in use. But on the real computer it deleted it fine.

So I guess this is just all a problem in my VPC. On my computer, when I'm running the VPC, it just about slows down almost anything else I try to do on my computer so it looks like there isn't any problem. I appreciate the reply through, since I was worried about this in case I was doing something wrong.

gridman
06-21-2007, 01:17 PM
I have been working with VPC and Virtual Server for the past two years and what you're saying is true. From what I've seen, virtual machines are pretty good, and pretty useful, but there is not a perfect one to one correspondance between what you see and experience on virtual machine and what you see and experience on a normal machine.

I haven't tried the new Virtual PC 2007 version yet. Will probably be using it soon.