PDA

View Full Version : QuickPatch in IS 12 Express cannot patch IS X Express



KingBill
06-19-2007, 03:53 AM
Hello,

we used IS X Express to deliver our Software KingBill. 2 months ago we buyed an upgrade to IS 12 Express. Both versions are in german language.

With IS 12 Express we had made a new installation but with the same product and upgrade code for KingBill, the same as we used in IS X Express. The installations work perfect.

Now the problem:
when we now make a QuickPatch with IS 12 Express for the KingBill software
and we install this Patch on a computer, that has installed the installation
with IS 12 Express we have no problems and the Patch works great. BUT: when we install the Patch on a machine with the installation we have made with IS X Express ... then the Patch cannot be installed and we get the Error:
"Interner Fehler 2715.kingbill.exe"

when we install the Patch on a machine with the installation we have made with IS X Express AND a has already installed a IS X Express QuickPatch (from 4.0.x to 4.0.20) then the Patch cannot be installed and we get the Error:
"Der Upgradepatch kann von Windows Installer Dienst nicht installiert werden, weil das Programm, das aktualisiert werden soll, möglicherweise fehlt oder weil der Upgradepatch eine andere Version des Programms aktualisieren würde. Stellen Sie sicher, dass das zu aktualisierende Programm auf dem Computer installiert ist und dass Sie den richtigen Upgrade Patch installieren."

It looks like Windows cannot update the same software, which is installed with IS X Express.

What Solution can you offer us?

Greetings from Vienna.

Ing. Alexander Kollin
King Software
office@kingbill.de
Phone: +43 1 8042808
Fax: +43 1 804 28 08-3
A-1130 Wien, Hermesstrasse 70