PDA

View Full Version : SAB Cannot Find InstasllScript Objects



esiemiat
06-18-2007, 11:31 AM
I am working with support regarding the following issue, but was wondering if anyone else was, or was not, experiencing the same issue.

I have a few InstallShield 2008 InstallScript objects that I cannot get to build with the SAB engine, but they build fine in the IDE. Basically, any included InstallScript objects cannot be found even though I have installed them using the same installs I used when configuring my development machine.

Below is a section of the log file that contains the error:

Generating RC file: _ISUser1033.rc
Building dialog CdSscRegisteredUser2
Built 1 dialogs into resource file: _ISUser1033.rc
Building RES file: _ISUser1033.res
Compiling resource DLL: _ISUser.dll
Loading Object: MainApp\MDAC 2.8 SP1 ...
Loading Object: MainApp\MS.NET Framework ...
Loading Object: MainApp\VB6 Runtime ...
ISDEV : error 125: Unable to load InstallShield Object(s): MainApp\MDAC 2.8 SP1,
MainApp\MS.NET Framework,
MainApp\VB6 Runtime
Automatic update notification disabled

I have tried creating empty projects that contain only a sinlge object, and have tried this on a variety of computers and on different operating systems. In all cases I recieve the same error. I also verified that the object files existed in the target folder, and that the standard object related registry keys were present.

esiemiat
06-18-2007, 01:33 PM
I fixed the issue. ISSETUP.DLL, a self-registering file mind you, gets installed to the TARGETDIR instead of the SYSTEM sub-folder like it does for the IDE install. Apparently there is some component in the SAB engine that is looking for this file in the SYSTEM folder. The solution is to copy, not move, the file into the SYSTEM sub-folder, and DO NOT register the now duplicate file.

Apparently the SAB installer does not use the same folder structure as the IDE installer and places a lot of files that should be in the SYSTEM subfolder directly under TARGETDIR. In this case that caused a big problem for an InstallScript projet that contained InstallScript objects. I think someone should cleanup the SAB install to make it match the folder structure of the IDE.

esiemiat
06-19-2007, 02:42 PM
Support just got back to me and gave me the same fix, so apparently this is the fix forthis bug. No ETA on a new install for the SAB yet.