PDA

View Full Version : .NET 1.1 on Vista, "may not have installed correctly" message



veetid
06-17-2007, 01:55 PM
I use IS 2008 with a Basic MSI project... I have .NET 1.1 included in the project and everything works fine on XP...

With Vista if .NET 1.1 is not already installed, half way through installing it you see "may have not installed correctly". If you tell it that it has, then it works fine...

How can I remove this message? If I manually run 1033dotnetfx.exe and the SP1 they install just fine...

I read about this in IS 12, but assumed it would already be fixed in IS 2008.

The only reason I purchased IS 2008 was for Vista compatiblity, is this not possible? Do I have to use CA?

david

jjb8297
12-18-2007, 01:07 PM
I use IS 2008 with a Basic MSI project... I have .NET 1.1 included in the project and everything works fine on XP...

With Vista if .NET 1.1 is not already installed, half way through installing it you see "may have not installed correctly". If you tell it that it has, then it works fine...

How can I remove this message? If I manually run 1033dotnetfx.exe and the SP1 they install just fine...

I read about this in IS 12, but assumed it would already be fixed in IS 2008.

The only reason I purchased IS 2008 was for Vista compatiblity, is this not possible? Do I have to use CA?

david

I just ran into this problem and was wondering if you got it resolved

MichaelU
12-19-2007, 01:20 PM
Have you installed the hotfix described on our KB?
http://support.installshield.com/kb/view.asp?articleid=Q113498

jjb8297
12-19-2007, 01:25 PM
Have you installed the hotfix described on our KB?
http://support.installshield.com/kb/view.asp?articleid=Q113498

Sorry, should have replied to the my earlier post yesterday, after some searching I did find the hotfix mentioned above and it did take care of the issue that I was encountering.