PDA

View Full Version : Windows Installer 3.x engine



ze_netio
06-07-2007, 04:35 PM
I installerd IS2008 and migrate my project from IS12 to 2008. I already have a Windows Service in this project. I would like to use windows installer 3.x engine on my project. When I try to drag 3.x object to a new feature I receive the message
The object Windows Installer 3.x Engine could not be inserted, you may need to reinstall the object in order to use it.
I already unintalled and reinstalled the object but IS2008 can not find. When I use Repair function I can see the message about installing 3.x Engine.
Drag 3.x engine in IS12 works fine. How can I fix this problem?
thanks

www.byteshift.com
:confused:

DevinEllingson
06-11-2007, 12:12 PM
ze_netio,

Did you install the IS2008 version of the object? Did you recieve any errors during this install?

Also, Did you customize the object source for this object at any time (Including versions of this object from previous versions?)

Devin Ellingson
Software Developer
InstallShield, A Macrovision Company

ze_netio
06-12-2007, 09:12 AM
Thanks for your reply.
To fix the problem I had to uninstall IS2008 two times. But now seems to be working fine. At least I can drag objects and make configurations.
Thanks.

:)

coedindigo
06-15-2007, 11:55 AM
Same thing happened with me..i updated IS2008 fully with patches and repaired it instead of uninstalling it..worked for me.

ze_netio
06-16-2007, 09:04 AM
Repair did not worked for me. I had to fully uninstall and install again.
After reinstall, IS2008 started to work and after install two patches that I need to use I decided not install the entire update package.