PDA

View Full Version : Packaging .NET 2.0 with a basic MSI



Radranic
06-07-2007, 02:59 PM
I have looked at all the help stuff I could find and it all explains everything on the .NET tab of the release section.

I set it to "Download from the Web", .NET 2.0, leave the URL as the one provided, as it seems to be an macrovision maintained reference. Yet when I test it out, nothing seems to happen. The machine does not have .NET 2.0, and even if I set it to show all the .NET installer details I still get nothing.

Any ideas?

RobertDickau
06-08-2007, 09:31 AM
As a sanity check, are you launching the installer from setup.exe or launching the MSI package directly?

Radranic
06-13-2007, 07:54 AM
Launching the MSI directly.

By the fact that you are asking that, I'm guessing that I should be running the exe?

RobertDickau
06-13-2007, 08:45 AM
Yes: many of the prerequisites are MSI-based, which means they need to be launched before your MSI is launched, which in turn means that end users must launch the setup.exe in order for the prerequisites to be installed.

Radranic
06-13-2007, 08:53 AM
Does this mean that the including .NET from the url will only when you aren't used a single exe or single msi type project?

Am I forced to use one where there are the MSIs and the separate launcher? Or is the single exe a valid use too?

RobertDickau
06-13-2007, 08:54 AM
Yes, either way (MSI inside or outside setup.exe) should be fine.

Radranic
06-13-2007, 02:50 PM
Perfect.

Thanks for the information. I just got it working, had my own problem of changing settings and not realizing I was still working on the MSI release... oops.