PDA

View Full Version : Try to migrate FLEXlm to FLEXnet



Degas1
06-05-2007, 10:15 AM
Hello,

I try to migrate FLEXlm to FLEXnet.

But when I try to compile my softwareI have a link error.

It miss lm_new.obj file in my FLEXnet package.

So I had try to generate it by use build.bat in the i86_n3 directory.

But I have this error :


lc_init failed: Invalid key data supplied.
FLEXnet Licensing error:-44,543
...
NMAKE : fatal error U1077: 'lmnewgen.exe' : return code '0x1'
Stop.

Have tou an idea ?

Thanks
Degas

RobertDickau
06-05-2007, 08:52 PM
Some things to check, for a start: If you're building the demo toolkit, you'll want to ensure the demo keys have not expired; or if you're build your vendor-specific toolkit, you'll want to ensure your publisher keys (and publisher name) in lm_code.h are correct.

Degas1
06-06-2007, 02:43 AM
Hello,

Thanks to reply,

I think I have both.

Actully, I try with the demo toolkit.

I have this licence.lic file (I copy the uncounted.lic file) :


# an uncounted license
FEATURE f2 demo 1.000 permanent uncounted HOSTID=ANY SIGN="..."

I just try to do :
build.bat DLL

And I have the error.

I have modify nothing in the demo toolkit.

Is it nomal that lm_new.obj is missing ?

Thanks.
Degas

RobertDickau
06-06-2007, 09:40 AM
If you look in the demo toolkit's machind/lm_code.h file, are there VENDOR_KEY and TRL_KEY values? It might be necessary to get demo keys before you can rebuild the toolkit. Can you still run lmflex and the other utilities and examples?

Also, what is the newer version you are testing?

Degas1
06-07-2007, 08:40 AM
Thanks for your reply

My boss give me the mail with all informations (differents keys)

So now it's working great :)

Thank you