View Full Version : Best Practices Issue

05-24-2007, 01:11 PM
I have the pro edition and had checked Enforce Setup Best Practices along with Vista validation.

I have several ISBP errors pertaining to DLLs importing deprecated API's. I understand what that is for and not a problem.

I now no longer want to enforce the best practices.

Logic would have it that I would uncheck the Enforce Setup Best Practices option and I would no longer be presented with ISBP errors.

I am still seeing them.

When option checked, show all pertaining ISBP errors, where applicable.
When option unchecked, no longer detect or show ISBP errors.

Lance Rasmussen

05-24-2007, 02:32 PM
The Enforce Setup Best Practices option in Tools -> Options has to do with the way that the Component Wizard will author components and not so much with the new Best Practices Validators.

You can go to the Tools -> Options -> Validation tab and select the "Customize" button and that should provide you the view necessary to disable the validators.

05-24-2007, 03:11 PM

Ok... I must be blind then. In the PRO version, when I go to Options > Validation > Customize.... where do I find ISBP##'s to disable?

I've looked at each of the CUB's in the drop down list box and see lots of ICE's and ISICE's depending on them. But I do not see any ISBPs.


Stefan Krueger
05-25-2007, 02:06 AM
In my understanding, Best Proactice validation is only available in the Premier edition, which explains why you don't see "InstallShield Best Proactice Suit" in the drop down box. Now I wonder why you are getting ISBP errors in the first place if you're using Professional.

05-25-2007, 11:07 AM
The Obsolete/Deprecated API checks were originally part of the Certified for Vista plus InstallShield ICEs suite, as we believed they were a requirement of logo certification. More recently we were unable to confirm this, and moved those checks to the InstallShield Best Practice suite. We didn't want to remove the functionality we had offered in the IS12 SP, and behind the scenes we share the code, so what was previously available as ISICE13-15 are now officially (and always reported as) ISBP17-19. You can disable these by deselecting ISICE14 and ISICE15 on the Certified for Vista suite.

05-25-2007, 04:20 PM
Thanks Michael,

This may be good to mention in appropriate documentation, unless I missed it somewhere. At least I can get rid of them now.

05-29-2007, 09:27 AM
It was a bit of a late breaking change; I'll send notes to make sure the people running the docs and KB are aware of this and can try to make this a little easier for the next person encountering it.