PDA

View Full Version : Internal Error 2228



bnix99
05-16-2007, 03:38 PM
We are evaluating the Installshield 12 Express version and I have converted our existing .ise files to the new project and everything builds and looks good. However, when trying to test the install on a Vista Ultimate machine I receive the attached error. I also get the same error when testing the install on a WIN2K machine.

Any guidance or help would be greatly appreciated.

Thanks,

Additional Information:

I should add that it appears the error is occurring as the line "Registering Extension Servers" is displayed on the progress screen.

TsungH
05-16-2007, 08:45 PM
If you have not, please look up 2228 at Support (http://support.installshield.com/) for available KB articles.

bnix99
05-17-2007, 08:36 AM
TsungH,

Thank you for the reply, and I actually did that prior to posting in this forum. While I was able to find a few 2228 errors, they applied to the Premium or Professional edition and it appears in a few cases an SP was able to solve the problem, but from what I can tell there are no SP's for the express edition.

I am going to continue looking into it and hopefully an "AHA" moment will take place.

Thanks,

bnix99
05-17-2007, 12:46 PM
It turns out that the error was becauase the msi was expecting a file extension in the VERB table. Although, no extensions are needed for our installation! after putting in an extension, the install goes through fine?

khadem1386
12-18-2007, 11:37 AM
Thank

I have same problem whit verb
Internal Error 2228., Verb,SELECT 'Verb','Command','Argument','Sequence' FROM
'Verb' WHERE 'Extension_'=? ORDER BY 'Sequence'

thank for yor help