PDA

View Full Version : "Unable to save file" error with Vista



benoit808
03-28-2007, 07:12 PM
I'm using Express 12 on my dev box which runs Windows XP. I can create an installer that runs great on 2K and XP but if I try to run the installer on Vista, I get the following error message:


Unable to save file: C:\Windows\Downloaded Installations{82C27800-C2A9-4171-96D1-58A78E

The system cannot find the path specified.


I can browse for a temp directory and the installation continues but does anyone have an idea why this is happening and how I can fix it?

Thanks

TheHouz
03-29-2007, 08:00 AM
That was an easy one.

Set the "Location for Copying Media" to [LocalAppDataFolder]




I'm using Express 12 on my dev box which runs Windows XP. I can create an installer that runs great on 2K and XP but if I try to run the installer on Vista, I get the following error message:


Unable to save file: C:\Windows\Downloaded Installations{82C27800-C2A9-4171-96D1-58A78E

The system cannot find the path specified.


I can browse for a temp directory and the installation continues but does anyone have an idea why this is happening and how I can fix it?

Thanks

benoit808
03-29-2007, 03:45 PM
Thanks TheHouz for your quick answer.
Can you just tell me where that option would be? I looked all over but I can't find it... must be blind!

TheHouz
03-30-2007, 08:01 AM
In Prepare Your Release, Build Your Release, I click on Single Image. It is there on the right


Thanks TheHouz for your quick answer.
Can you just tell me where that option would be? I looked all over but I can't find it... must be blind!

benoit808
03-30-2007, 01:21 PM
Got it!

thanks a lot

JoeBacon
04-09-2007, 04:45 PM
I was having the same problem so I appreciate the info.

Where does [LocalAppDataFolder] map to on the target system?

Also, I am setting up my system to create a verbose log just during QA on my project. I have it set up to log to the the root directory (c:\) which is apparently not allowed in Vista.

Where would be the appropriate place in vista to have my install log to?

TsungH
04-10-2007, 03:37 AM
If you have not, please refer to LocalAppDataFolder Property (http://msdn2.microsoft.com/en-us/library/aa369768.aspx).

Chip Keen
10-29-2008, 01:26 PM
In Express 2008, setting the Installation Designer / Builds / Single Image (e.g.) / Setup.exe / Cache Path to [LocalAppDataFolder] takes care of the error.