PDA

View Full Version : .ini File Permissions



ddickins
02-20-2007, 04:50 AM
I've user the repackager function in Admin Studio 8 to record and re-package some software to install onto a WinXP client.

The user needs to be able to write to one of the .ini files created, however they don't have permission. I've tried changing the permissions on the parent folder, but this seems to make no difference. The .ini file is built using the "INI File Changes" part of InstallShield, and I can't find anywhere on this section to set any permissions.

To try to get around this, I've added the .ini file to the "Files and Folders" section, which created it's own component, but this doesn't seem to get included in the .msi package. I've checked the "Components" sections, and the component in question has an "!" on the icon (see attachment). I've checked every option under the .ini component against some of the components around it, but can't find any problems.

Any help would be appreciated!

Thanks

Daniel

TsungH
02-21-2007, 02:04 AM
In order for a component to be installed, it must be associated with a feature. Components that are not associated with a feature are displayed with the orphaned component icon, which is normal component with a red exclamation mark. For more info, click on the Components node at the top of the view.

Makumazan
02-21-2007, 08:43 AM
In our practice, when ini-file exists in AdminStudio ini-section, for permission setting we are using property in Property Table, which has relationship with merge module based on SetACL.ocx

As result we not need create additional component for ini-file, and project is enoughly transparent for viewing and editing.