PDA

View Full Version : Some Target Location Runtime Variables are not defined



pkass02
01-23-2007, 07:29 PM
I have two file sets. The Target Location of the first one is set to $[OSFolder], that of the second one to $[CommonAppDataFolder]

When I run the unit test, I get:

Unit Test: ISDEV : error -9034: Unable to resolve value for path variable '$[OSFolder]' in target path $[OSFolder]. The path variable is referenced in the DIM, but is not defined in the project file consuming this DIM.

If I change $[OSFolder] e.g. to $[CommonFilesFolder], it works fine again.

It seems to me, as if all variables starting with "$[OS...]" can not be used.

What is wrong ??

And: does really anyone use Collaboration ? Not much traffic in this forum ... :rolleyes:

pkass02
01-23-2007, 08:31 PM
Although I still do not know, why some of the predefines runtime variable are ok and some are not -
I found out, that I just can set these runtime variables in the runtime variables tab for the unit test to pass.
When i reference the DIM in a Basic MSI project, I can override these test settings.

I still wonder how I can set the [WindowsFolder] from the directory table for my $[OSFolder] ... it is only pssible to select public properties from the property table ...

And after hours of searching I found in the documentation ("Reviewing the Contents of a Referenced DIM "):
"For run-time variables, you must set the Value field to a hard-coded value or to a Windows Installer property. " ==> hard to believe !! :eek:

pkass02
01-23-2007, 08:34 PM
Now I found out, that you can use the directories of the directory table as values of DIM runtime variables, e.g. "[WindowsFolder]".

Why is this important issue missing in the documentation ??
:confused:

pkass02
01-23-2007, 08:46 PM
Another shocking setbacks:

- file permissions do not work:
I tried to set a file to read- and writeable for all users - but it isn't

- file attributes do not work:
I tried to set a file to "hidden" and "system", but it did not work.

- No permission settings for registry keys possible

- No setting permanent/non-permanent for registry keys possible.

That means for me: I cannot use DIMs and must go back to my InstallShield
11.5 IDE and implement it directly in the Basic MSI project ... :( :( :(

mehajure
07-17-2007, 07:27 AM
Hi pkass02,

I know you had your trouble some months ago, but I found your post today and I like to share this with anyone interested in this forum. It might save time and nervs.

I had a similar problem with permissions until I found out that the main "error" was that the "Domain" entry in the LockPermissions Table should not be used when granting rights to user groups. It worked only for single users as expected. So leave it empty.
It was helpful for me to use and analyse the little merge module posted on installsite:

http://www.installsite.org/files/iswi/SIDLookup.zip

The paragraph is named :
"Using the LockPermissions Table on Localized Windows Versions"
and located at :
http://www.installsite.org/pages/en/msi/tips.htm

Hope it helps.:)