View Full Version : Can not delete entries in INI File Changes step

Mark Stegall
01-22-2007, 06:43 PM
I have run into a fatal bug that at times causes ISExpress 12 to crash. Most of the time is results in ***IS_STRING_NOT_DEFINED*** entries.

I added INI file entries along with keyowrds and then tried to delete some of them. It has resulted in the ***IS_STRING_NOT_DEFINED*** as the INI filename and SectionName fields. I can not get rid of them. The project build without errors or warnings but can not be installed becuaes of the same error.

Has anybody else seen this and have a suggestion for a work around?

01-29-2007, 12:56 PM
I have the same issue. Can't find a way around it.

Mark Stegall
01-29-2007, 02:19 PM
I have requested assistance from Macrovision on this. Along with sending them detailed instructions on how to replicate the probelm. I will post what I learn.

01-29-2007, 02:54 PM
I was able to clear the bad entries by deleting the individual Keywords below the ***IS_STRING_NOT_DEFINED*** entries first, saving the project, then going back in and deleting the Sections, and finally the ***IS_STRING_NOT_DEFINED*** INI entries themselves. They didn't return and install works now.

Mark Stegall
01-29-2007, 04:56 PM
It took me awhile to delete the keys first then the sections and then the ini files because ISE 12 kept crashing when certains sections and INIs were deleted. I had to repeatedly; add dummy entries, save, load and then delete the entries. I finally got my project cleared of the INI File Changes entries.

Macrovision did acknowledge they could recreate the problem and hopefully will be getting back to me soon. I really need to be able to use the INI File Changes to properly update our projects.

Mark Stegall
02-13-2007, 08:53 PM
Macrovision has acknowledged this is a bug in the ISE 12. The only thing we can do is wait for a patch from Macrovision to show up in thier updates.