View Full Version : Custom Action EXE fails on Vista

01-08-2007, 02:59 PM
To attempt to reduce the size of my download, I thought I'd run the .Net 1.1 Framework installer as an EXE custom action. However when I run it, I get an error 1722 saying that it unexpectedly failed.

I'm running 1033dotnetfx.com with the command line /q:a /c:"install /l /q" (as used in InstallShield Express X to install it).

When I run it manually from the Vista command line with the above arguments it installs perfectly without errors.

The custom action is placed in After Setup Progress Dialog.

Any idea why this doesn't work?

More info: Require Administrator is Yes and Required Execution Level is Administrator.


- Jerry

01-09-2007, 06:05 PM
Perhaps, you want to provide complete settings of your custom action.

To troubleshoot, you can turn on verbose log (using /l*v c:\install.log).

01-09-2007, 08:36 PM
Sure, the attachment is a screen shot showing the settings. Thanks for the logging suggestion. I'll try it.

01-11-2007, 09:56 PM
Unfortunately, that doesn't help me understand it any better. I was hoping otherwise. It you can post a screenshot of CustomAction table of the MSI file, that should give me a better idea. You can use Orca (a free utility from Microsoft) to view and edit MSI file directly.

01-12-2007, 12:34 PM
What information are you actually looking for?

This is InstallShield Express so I'm just setting the options you see in the screenshot. I'm not doing anything more than that.

01-12-2007, 02:24 PM
The log file and the error message you are seeing (if any) would be greatly helpful in resolving this issue :)

Unfortunately, Express doesn't really show the options we need to see exactly what's going on.

However - if you install .NET assemblies to the GAC or rely on .NET installer classes, this method will not work. Windows Installer determines if you have .NET on the system when MSI is launched.

01-12-2007, 03:31 PM
This particular problem is no longer an issue for us. We confirmed with InstallShield Support that it is impossible for the InstallShield 12 Express installer to install the .Net 1.1 Framework on Vista. We're working on another method to get .Net 1.1 onto user's machines.

Meanwhile this is the real pressing problem we're having related to custom actions: http://community.installshield.com/showthread.php?t=165791

- Jerry

01-13-2007, 03:57 AM
I was trying to find out custom action type, its In-Script Execution Option, and what actually goes into each column in CustomAction table.

Hmm... they said it's impossible?! Fine. I am not going to argue otherwise, since I don't have access to Express 12 for further verification.