PDA

View Full Version : An unknown error occurred



AnthonPr
11-14-2006, 09:45 AM
I'm not sure why, but I keep receiving that error when trying to build a package in the Repackager. I keep getting the following:

Starting conversion
Creating Developer project: C:\Packages\MyPackage.ism
Reading repackager output file
Loading registry entries
Creating components for the files captured
An unknown error occurred

Conversion stopped with 1 error(s) and 0 warning(s).

I verified, and I do NOT have the "Replace files with merge modules whenever possible" option checked. I'm not sure what else could be the problem. Please help. Any assistance is greatly appreciated.

Cary R
11-15-2006, 12:57 AM
These are really, really tough to troubleshoot. Basically, you'll want to just start excluding file and registry data until it builds the *.ism successfully.

Like a CS professor of mine once said, "Divide and Conquer". Start by excluding half of all data. Then when you find the half that lets you build successfully, exclude everything but one half of that subset, and so on...

It takes a while, but eventually you end up with the culprit. I'll see if I can do some searching through old files and find the source of this problem the last time I had encountered it....

Cary R
11-15-2006, 03:47 PM
Looks like what happened last time I ran into this was due to some files captured in the following path:

[USERPROFILE]Local Settings

I beleive there was a bug report submitted as a part of this to be addressed in AdminStudio 8.0. Do you see that there is data present here in your repackaged output?